summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Inline-Python
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Inline-Python')
-rw-r--r--dev-perl/Inline-Python/Inline-Python-0.460.0.ebuild35
-rw-r--r--dev-perl/Inline-Python/Inline-Python-0.490.0.ebuild38
-rw-r--r--dev-perl/Inline-Python/Manifest2
-rw-r--r--dev-perl/Inline-Python/files/Inline-Python-0.460.0-insanepython.patch20
-rw-r--r--dev-perl/Inline-Python/metadata.xml12
5 files changed, 107 insertions, 0 deletions
diff --git a/dev-perl/Inline-Python/Inline-Python-0.460.0.ebuild b/dev-perl/Inline-Python/Inline-Python-0.460.0.ebuild
new file mode 100644
index 000000000000..49aac017a68a
--- /dev/null
+++ b/dev-perl/Inline-Python/Inline-Python-0.460.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+# Feel free to add more targets after testing.
+
+MODULE_AUTHOR=NINE
+MODULE_VERSION=0.46
+inherit python-single-r1 perl-module
+
+DESCRIPTION="Easy implementation of Python extensions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Data-Dumper
+ virtual/perl-Digest-MD5
+ >=dev-perl/Inline-0.46
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=( "${FILESDIR}/${P}-insanepython.patch" )
+
+SRC_TEST="do"
diff --git a/dev-perl/Inline-Python/Inline-Python-0.490.0.ebuild b/dev-perl/Inline-Python/Inline-Python-0.490.0.ebuild
new file mode 100644
index 000000000000..d5a569f130ba
--- /dev/null
+++ b/dev-perl/Inline-Python/Inline-Python-0.490.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+# Feel free to add more targets after testing.
+
+MODULE_AUTHOR=NINE
+MODULE_VERSION=0.49
+inherit python-single-r1 perl-module
+
+DESCRIPTION="Easy implementation of Python extensions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Data-Dumper
+ >=virtual/perl-Digest-MD5-2.500.0
+ >=dev-perl/Inline-0.46
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ virtual/perl-Test
+ )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.460.0-insanepython.patch" )
+
+SRC_TEST="do"
diff --git a/dev-perl/Inline-Python/Manifest b/dev-perl/Inline-Python/Manifest
new file mode 100644
index 000000000000..a1b878d3dc4e
--- /dev/null
+++ b/dev-perl/Inline-Python/Manifest
@@ -0,0 +1,2 @@
+DIST Inline-Python-0.46.tar.gz 55436 SHA256 f6332ddd2e8069a2c20f7f6528bc4f44643611ef4cff66d90e5b48dfdca5db0d SHA512 d7c26faf386ac74dddc0298d5d572117a9b0b9a604bf23d253e154f5cea7a3911b426cff9bae9cca2730ec1948a40a919bdef26c048035d2367f3e463581a68c WHIRLPOOL 4ad4dcccc889c6ff1a9352cc238c3d03866fe2bec498b5f63932fc7ceb20d02e315b6f6918aa2bec71059782ac476107e19192c84bef9b07463e518e28562266
+DIST Inline-Python-0.49.tar.gz 56811 SHA256 10c9419651c7b345fa7ec922f4a9d6287fd5a69761f4240f9e0b21f0944f8bf3 SHA512 5495e8d4d22472ff0b58b8dcae4e12cb037a8629dcd059e3d2509d85c1e405be645ab9499480248a978e7b25004fd1fe65436f34f9f92bdd9150ea1401fa4720 WHIRLPOOL 62fc439c78c03ad24d310ac8749b8c0733072b1adc3d4a5c44fb20231134d4c8e792c883bccd12bba3f183be239be60723dba02819617ece9f98792823d77da4
diff --git a/dev-perl/Inline-Python/files/Inline-Python-0.460.0-insanepython.patch b/dev-perl/Inline-Python/files/Inline-Python-0.460.0-insanepython.patch
new file mode 100644
index 000000000000..b713f170abe8
--- /dev/null
+++ b/dev-perl/Inline-Python/files/Inline-Python-0.460.0-insanepython.patch
@@ -0,0 +1,20 @@
+diff -ruN Inline-Python-0.46.orig/Makefile.PL Inline-Python-0.46/Makefile.PL
+--- Inline-Python-0.46.orig/Makefile.PL 2014-12-07 12:35:25.478476508 +0100
++++ Inline-Python-0.46/Makefile.PL 2014-12-11 00:37:37.580577317 +0100
+@@ -134,7 +134,7 @@
+ $ref->{libpath} = join '/', (get_config_var($ref, "LIBDEST"),
+ 'config')
+ if ($ref->{libpath} eq 'None');
+- return query_options($ref) unless sanity_check($ref);
++ return $ref;
+ }
+
+ sub test_interrogate {
+@@ -171,6 +171,7 @@
+ Extra Libs: $sel->{syslibs}
+ Python Library: $sel->{libpath}/$sel->{libpython}
+ Include Path: $sel->{incpath}
++
+ END
+ # ' stupid vim.
+ }
diff --git a/dev-perl/Inline-Python/metadata.xml b/dev-perl/Inline-Python/metadata.xml
new file mode 100644
index 000000000000..4c1f6a4f464c
--- /dev/null
+++ b/dev-perl/Inline-Python/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Inline-Python</remote-id>
+ <remote-id type="cpan-module">Inline::Python</remote-id>
+ <remote-id type="cpan-module">Inline::Python::Function</remote-id>
+ <remote-id type="cpan-module">Inline::Python::Object</remote-id>
+ <remote-id type="cpan-module">Inline::Python::Object::Data</remote-id>
+ </upstream>
+</pkgmetadata>