summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-05-29 23:34:25 +1200
committerKent Fredric <kentnl@gentoo.org>2017-05-29 23:34:49 +1200
commit812f6bbdc8f6fde6ed6810abf9ff0a34f1df9757 (patch)
tree3f00f96e9891f5984bf2250c6d595aeeafc638b9 /dev-perl/JSON/JSON-2.940.0.ebuild
parentapp-text/editorconfig-core-c: amd64 stable wrt bug #620026 (diff)
downloadgentoo-812f6bbdc8f6fde6ed6810abf9ff0a34f1df9757.tar.gz
gentoo-812f6bbdc8f6fde6ed6810abf9ff0a34f1df9757.tar.bz2
gentoo-812f6bbdc8f6fde6ed6810abf9ff0a34f1df9757.zip
dev-perl/JSON: Bump to version 2.940.0
- EAPI6 - Add USE="examples" - Add USE="xs" Upstream: - Add support for explicit backend of Cpanel::JSON::XS - convert_blessed_universally and support_by_pp now safer - Documentation and test fixes - Remove base.pm dependency - Add VERSION methods Keywords: - new dep JSON-XS - Drop keywords: amd64-fbsd arm64 hppa x86-fbsd Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-perl/JSON/JSON-2.940.0.ebuild')
-rw-r--r--dev-perl/JSON/JSON-2.940.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/JSON/JSON-2.940.0.ebuild b/dev-perl/JSON/JSON-2.940.0.ebuild
new file mode 100644
index 000000000000..92ebaa7d0752
--- /dev/null
+++ b/dev-perl/JSON/JSON-2.940.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ISHIGAKI
+DIST_VERSION=2.94
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="JSON (JavaScript Object Notation) encoder/decoder"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test +xs"
+
+RDEPEND="xs? ( >=dev-perl/JSON-XS-2.340.0 )"
+DEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+src_test() {
+ perl_rm_files t/00_pod.t
+ perl-module_src_test
+}