summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-10 22:02:36 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-12 00:54:10 +0200
commit0b08b57171c81225bf7217354457b5ffa02ba459 (patch)
tree2a4422a3d5932966100f0dbb526a694ef16426f8 /dev-perl/Shell/Shell-0.730.0.ebuild
parentdev-perl/Scope-Guard: Bump to version 0.210.0 (diff)
downloadgentoo-0b08b57171c81225bf7217354457b5ffa02ba459.tar.gz
gentoo-0b08b57171c81225bf7217354457b5ffa02ba459.tar.bz2
gentoo-0b08b57171c81225bf7217354457b5ffa02ba459.zip
dev-perl/Shell: Bump to version 0.730.0
- EAPI6 - Cleanup tests and provide missing deps Upstream: - Minor packaging and documentation fixes Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/Shell/Shell-0.730.0.ebuild')
-rw-r--r--dev-perl/Shell/Shell-0.730.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/Shell/Shell-0.730.0.ebuild b/dev-perl/Shell/Shell-0.730.0.ebuild
new file mode 100644
index 000000000000..a51a1fb37d40
--- /dev/null
+++ b/dev-perl/Shell/Shell-0.730.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=FERREIRA
+DIST_VERSION=0.73
+inherit perl-module
+
+DESCRIPTION="Run shell commands transparently within perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="virtual/perl-File-Spec"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+src_test() {
+ perl_rm_files "t/99_pod.t"
+ perl-module_src_test
+}