summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-11-17 22:39:59 +0000
committerJoonas Niilola <juippis@gentoo.org>2021-01-18 10:54:59 +0200
commit0fd903a3055957695d8d11b23c947c020ec50eca (patch)
treeb1ee5bdc50a2e92ecb833f1104188c88fb5e06e9 /dev-perl
parentsys-fs/cryfs: add python3_9 to PYTHON_COMPAT (diff)
downloadgentoo-0fd903a3055957695d8d11b23c947c020ec50eca.tar.gz
gentoo-0fd903a3055957695d8d11b23c947c020ec50eca.tar.bz2
gentoo-0fd903a3055957695d8d11b23c947c020ec50eca.zip
dev-perl/Gtk3-ImageView: version bump - 6
Disabling parallel test due to https://github.com/carygravel/gtk3-imageview/issues/18 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/18766 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Gtk3-ImageView/Gtk3-ImageView-6.0.0.ebuild41
-rw-r--r--dev-perl/Gtk3-ImageView/Manifest1
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Gtk3-ImageView/Gtk3-ImageView-6.0.0.ebuild b/dev-perl/Gtk3-ImageView/Gtk3-ImageView-6.0.0.ebuild
new file mode 100644
index 000000000000..ebce005b7376
--- /dev/null
+++ b/dev-perl/Gtk3-ImageView/Gtk3-ImageView-6.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=RATCLIFFE
+DIST_VERSION=6
+DIST_TEST=do
+inherit perl-module virtualx
+
+DESCRIPTION="Image viewer widget for Gtk3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-perl/Cairo
+ >=dev-perl/glib-perl-1.210.0
+ dev-perl/Gtk3
+ dev-perl/Readonly
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Carp-Always
+ dev-perl/Test-Differences
+ dev-perl/Test-MockObject
+ dev-perl/Try-Tiny
+ media-gfx/imagemagick[jpeg,perl,png,svg,X]
+ virtual/perl-Test-Simple
+ )
+"
+
+PERL_RM_FILES=(
+ t/90_MANIFEST.t
+ t/91_critic.t
+)
+
+src_test() {
+ virtx perl-module_src_test
+}
diff --git a/dev-perl/Gtk3-ImageView/Manifest b/dev-perl/Gtk3-ImageView/Manifest
index c91e269e8baf..597aab921a23 100644
--- a/dev-perl/Gtk3-ImageView/Manifest
+++ b/dev-perl/Gtk3-ImageView/Manifest
@@ -1 +1,2 @@
DIST Gtk3-ImageView-4.tar.gz 14329 BLAKE2B e4dee495e83392cc14e8fbd050658a1647bfa3f71e3711610e4df502d92adcce67800fd3c1e5ce09464fdb2e22a92ad7a1bdb52fb119f86712ef898cbf208abf SHA512 d723fb826f510ceccc6116b43baac4e1e42b59f91a0da5d8e9acf5b4ce608807119533fa965ba5aa623511aa9843b81488fd931d58417a2f3dd4f5db45238d64
+DIST Gtk3-ImageView-6.tar.gz 15444 BLAKE2B 1f026895328912443d4e08fbeb2ee9826818c09b00d06f087417f141d2c5b193e13840a09162c47fc5c0d642d0738cf290038a541f5e14303382a14a0245213d SHA512 68fc3371fe3d62163523d81732f0716fe15623a53139e8050e3bddc12c694a9ae2e89855b9926e14b18803e9c7a586b925b613e1cf364cb449b850fe70b571ab