summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-07-02 17:30:42 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-07-02 17:30:42 +0200
commit4fad844b29460d23cab8791b4794205a5d90344f (patch)
tree49d2302a856b12f9e3bb7440d2c9939153579137 /dev-perl
parentdev-perl/perl-ldap: Add build fix for Perl 5.26, bug 623078 (diff)
downloadgentoo-4fad844b29460d23cab8791b4794205a5d90344f.tar.gz
gentoo-4fad844b29460d23cab8791b4794205a5d90344f.tar.bz2
gentoo-4fad844b29460d23cab8791b4794205a5d90344f.zip
dev-perl/PPI-PowerToys: Add build fix for Perl 5.26, bug 623080
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/PPI-PowerToys/PPI-PowerToys-0.140.0.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/dev-perl/PPI-PowerToys/PPI-PowerToys-0.140.0.ebuild b/dev-perl/PPI-PowerToys/PPI-PowerToys-0.140.0.ebuild
index cf1a70541f13..557307d6dff1 100644
--- a/dev-perl/PPI-PowerToys/PPI-PowerToys-0.140.0.ebuild
+++ b/dev-perl/PPI-PowerToys/PPI-PowerToys-0.140.0.ebuild
@@ -1,21 +1,20 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-MODULE_AUTHOR="ADAMK"
-MODULE_VERSION=0.14
+DIST_AUTHOR="ADAMK"
+DIST_VERSION=0.14
inherit perl-module
DESCRIPTION="A handy collection of small PPI-based utilities"
-LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
-DEPEND="
+RDEPEND="
>=dev-perl/File-Find-Rule-0.32
>=dev-perl/File-Find-Rule-Perl-1.10
>=dev-perl/Test-Script-1.70.0
@@ -23,3 +22,10 @@ DEPEND="
dev-perl/PPI
dev-perl/IPC-Run3
"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install::DSL/use lib q[.];\nuse inc::Module::Install::DSL/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}