summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-17 14:14:45 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-17 14:15:01 -0500
commit9649c91c29e430eb5f7ea0796ed7df69dfa549c6 (patch)
tree476d0aac0ac6aea9b3154859cbd4ae3f5e17f707 /dev-php
parentarch/arm/package.use.stable.mask: Mask galera for mariadb, needs more testing (diff)
downloadgentoo-9649c91c29e430eb5f7ea0796ed7df69dfa549c6.tar.gz
gentoo-9649c91c29e430eb5f7ea0796ed7df69dfa549c6.tar.bz2
gentoo-9649c91c29e430eb5f7ea0796ed7df69dfa549c6.zip
dev-php/pecl-rrd: new EAPI=6 revisions.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-rrd/pecl-rrd-1.1.3-r1.ebuild (renamed from dev-php/pecl-rrd/pecl-rrd-1.1.3.ebuild)14
-rw-r--r--dev-php/pecl-rrd/pecl-rrd-2.0.1-r1.ebuild (renamed from dev-php/pecl-rrd/pecl-rrd-2.0.1.ebuild)14
2 files changed, 12 insertions, 16 deletions
diff --git a/dev-php/pecl-rrd/pecl-rrd-1.1.3.ebuild b/dev-php/pecl-rrd/pecl-rrd-1.1.3-r1.ebuild
index 1eafe604d8c3..86088f91c816 100644
--- a/dev-php/pecl-rrd/pecl-rrd-1.1.3.ebuild
+++ b/dev-php/pecl-rrd/pecl-rrd-1.1.3-r1.ebuild
@@ -1,19 +1,17 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-USE_PHP="php5-6 php5-5 php5-4"
+USE_PHP="php5-6"
-inherit php-ext-pecl-r2
-
-KEYWORDS="~amd64 ~x86"
+inherit php-ext-pecl-r3
DESCRIPTION="RRDtool bindings for PHP"
LICENSE="BSD"
-
SLOT="0"
+KEYWORDS="~amd64 ~x86"
-DEPEND=">=net-analyzer/rrdtool-1.4.5-r1[graph]"
+DEPEND="net-analyzer/rrdtool[graph]"
RDEPEND="${DEPEND}"
diff --git a/dev-php/pecl-rrd/pecl-rrd-2.0.1.ebuild b/dev-php/pecl-rrd/pecl-rrd-2.0.1-r1.ebuild
index 847faf4bc26d..4c7f7598834c 100644
--- a/dev-php/pecl-rrd/pecl-rrd-2.0.1.ebuild
+++ b/dev-php/pecl-rrd/pecl-rrd-2.0.1-r1.ebuild
@@ -1,23 +1,21 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
# Define 5.6 here to have the {,REQUIRED_}USE generated
-USE_PHP="php7-0 php5-6"
+USE_PHP="php5-6 php7-0"
-inherit php-ext-pecl-r2
+inherit php-ext-pecl-r3
# But we really only build 7.0
USE_PHP="php7-0"
-KEYWORDS="~amd64 ~x86"
-
DESCRIPTION="RRDtool bindings for PHP"
LICENSE="BSD"
-
SLOT="7"
+KEYWORDS="~amd64 ~x86"
-DEPEND=">=net-analyzer/rrdtool-1.4.5-r1[graph]"
+DEPEND="net-analyzer/rrdtool[graph]"
RDEPEND="${DEPEND} php_targets_php5-6? ( ${CATEGORY}/${PN}:0 )"