summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-12-21 09:38:14 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-23 00:08:11 +0100
commitd57cf23fe9ef723921fb81a8feccfb427a690dc6 (patch)
tree7323fceffe0b215f49119a710b20393ef09eee7d /dev-php
parentdev-php/symfony-console: bump to 2.8.48 (diff)
downloadgentoo-d57cf23fe9ef723921fb81a8feccfb427a690dc6.tar.gz
gentoo-d57cf23fe9ef723921fb81a8feccfb427a690dc6.tar.bz2
gentoo-d57cf23fe9ef723921fb81a8feccfb427a690dc6.zip
dev-php/xdebug-handler: bump to 1.3.1
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xdebug-handler/Manifest1
-rw-r--r--dev-php/xdebug-handler/xdebug-handler-1.3.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/xdebug-handler/Manifest b/dev-php/xdebug-handler/Manifest
index a82901d359ff..fec61186707f 100644
--- a/dev-php/xdebug-handler/Manifest
+++ b/dev-php/xdebug-handler/Manifest
@@ -1 +1,2 @@
DIST xdebug-handler-1.3.0.tar.gz 12363 BLAKE2B ad89580e57728a444958d72f236fee14665f6fbed998018a28b181cdfc3a448da0a06dc335c3d95413eff6f6b92fc3d44ac8c03da282eb3dc65ae14600430825 SHA512 ed0206982c5ffab3c8ff56dcf8055230aaa358fbe89c15880cfce33abc27adb3b13f75bf7d78988f6bae4d0d072c66f557cd93082e89e7ca7993b257c04a2c61
+DIST xdebug-handler-1.3.1.tar.gz 12589 BLAKE2B fcee0a2412473f5e7a07defa96b991803728f831c8ab0dfa053c3ff8671a2dd187d5199e51ac90579830f5a005038411c2097be8a1f1370e8e06d090922f508a SHA512 a00d9cb8e23cd6bbad6c25f82c8db314451a88f49d90e755a9c81fa57794ecc79612481e031d60cdb2ee4fd4e256ffc02e847c76089daf720f8811659799131e
diff --git a/dev-php/xdebug-handler/xdebug-handler-1.3.1.ebuild b/dev-php/xdebug-handler/xdebug-handler-1.3.1.ebuild
new file mode 100644
index 000000000000..34166878b535
--- /dev/null
+++ b/dev-php/xdebug-handler/xdebug-handler-1.3.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Restart a CLI process without loading the xdebug extension"
+HOMEPAGE="https://github.com/composer/xdebug-handler"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader
+ >=dev-php/psr-log-1.0.2"
+
+src_install() {
+ insinto /usr/share/php/Composer/XdebugHandler
+ doins src/*.php "${FILESDIR}/autoload.php"
+ dodoc README.md
+}