summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-11-24 14:11:17 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-11-26 14:26:23 +0100
commitf305b8dd7a0ccca48dc96554b2d7ce075d3aedc9 (patch)
treefc25b1032a37a9fe67cf6723432144e5e5b79fcd /dev-php
parentnet-libs/zeromq: security cleanup (diff)
downloadgentoo-f305b8dd7a0ccca48dc96554b2d7ce075d3aedc9.tar.gz
gentoo-f305b8dd7a0ccca48dc96554b2d7ce075d3aedc9.tar.bz2
gentoo-f305b8dd7a0ccca48dc96554b2d7ce075d3aedc9.zip
dev-php/pecl-zmq: drop USE=czmq
<net-libs/czmq-3 is going away. Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-zmq/metadata.xml3
-rw-r--r--dev-php/pecl-zmq/pecl-zmq-1.1.3-r2.ebuild25
-rw-r--r--dev-php/pecl-zmq/pecl-zmq-1.1.3-r3.ebuild28
-rw-r--r--dev-php/pecl-zmq/pecl-zmq-9999.ebuild26
4 files changed, 41 insertions, 41 deletions
diff --git a/dev-php/pecl-zmq/metadata.xml b/dev-php/pecl-zmq/metadata.xml
index 0a03180aed3b..b86acf66c756 100644
--- a/dev-php/pecl-zmq/metadata.xml
+++ b/dev-php/pecl-zmq/metadata.xml
@@ -5,7 +5,4 @@
<email>php-bugs@gentoo.org</email>
<name>PHP</name>
</maintainer>
- <use>
- <flag name="czmq">Use the czmq high level bindings</flag>
- </use>
</pkgmetadata>
diff --git a/dev-php/pecl-zmq/pecl-zmq-1.1.3-r2.ebuild b/dev-php/pecl-zmq/pecl-zmq-1.1.3-r2.ebuild
deleted file mode 100644
index 5e4b0582a2af..000000000000
--- a/dev-php/pecl-zmq/pecl-zmq-1.1.3-r2.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3 php7-4"
-
-inherit php-ext-pecl-r3
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="PHP Bindings for ZeroMQ messaging"
-LICENSE="BSD"
-SLOT="0"
-IUSE="czmq"
-
-RDEPEND="net-libs/zeromq czmq? ( <net-libs/czmq-3:= )"
-DEPEND="${RDEPEND} virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}"/${P}-php7-3-compatibility.patch )
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=( $(use_with czmq) )
- php-ext-source-r3_src_configure
-}
diff --git a/dev-php/pecl-zmq/pecl-zmq-1.1.3-r3.ebuild b/dev-php/pecl-zmq/pecl-zmq-1.1.3-r3.ebuild
new file mode 100644
index 000000000000..d183c65cd902
--- /dev/null
+++ b/dev-php/pecl-zmq/pecl-zmq-1.1.3-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+USE_PHP="php7-2 php7-3 php7-4"
+inherit php-ext-pecl-r3
+
+if [[ ${PV} == "9999" ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/mkoppanen/php-zmq.git"
+ EGIT_CHECKOUT_DIR="${PHP_EXT_S}"
+
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="PHP Bindings for ZeroMQ messaging"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="net-libs/zeromq"
+RDEPEND="net-libs/zeromq:="
+
+PATCHES=( "${FILESDIR}"/${PN}-1.1.3-php7-3-compatibility.patch )
diff --git a/dev-php/pecl-zmq/pecl-zmq-9999.ebuild b/dev-php/pecl-zmq/pecl-zmq-9999.ebuild
index 945516fcd0c0..538ecc14c75d 100644
--- a/dev-php/pecl-zmq/pecl-zmq-9999.ebuild
+++ b/dev-php/pecl-zmq/pecl-zmq-9999.ebuild
@@ -4,23 +4,23 @@
EAPI="7"
USE_PHP="php7-2 php7-3 php7-4"
+inherit php-ext-pecl-r3
-inherit php-ext-pecl-r3 git-r3
+if [[ ${PV} == "9999" ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/mkoppanen/php-zmq.git"
+ EGIT_CHECKOUT_DIR="${PHP_EXT_S}"
-KEYWORDS=""
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="PHP Bindings for ZeroMQ messaging"
LICENSE="BSD"
SLOT="0"
-IUSE="czmq"
+IUSE=""
-RDEPEND="net-libs/zeromq czmq? ( net-libs/czmq:= )"
-DEPEND="${RDEPEND} virtual/pkgconfig"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/mkoppanen/php-zmq.git"
-EGIT_CHECKOUT_DIR="${PHP_EXT_S}"
-
-src_configure() {
- local PHP_EXT_ECONF_ARGS=( $(use_with czmq) )
- php-ext-source-r3_src_configure
-}
+BDEPEND="virtual/pkgconfig"
+DEPEND="net-libs/zeromq"
+RDEPEND="net-libs/zeromq:="