summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-01-03 11:55:55 -0600
committerWilliam Hubbs <williamh@gentoo.org>2017-01-05 18:07:57 -0600
commitbef2b64cbf2345a34a581e1a67d06c7fc0005bcf (patch)
treec8748bccbe30084e5fef9015988ab6f2a022b806 /dev-python/MechanicalSoup
parentapp-emulation/docker: Version bump to 1.13.0_rc5 (diff)
downloadgentoo-bef2b64cbf2345a34a581e1a67d06c7fc0005bcf.tar.gz
gentoo-bef2b64cbf2345a34a581e1a67d06c7fc0005bcf.tar.bz2
gentoo-bef2b64cbf2345a34a581e1a67d06c7fc0005bcf.zip
dev-python/MechanicalSoup: initial ebuild
Package-Manager: Portage-2.3.0, Repoman-2.3.1
Diffstat (limited to 'dev-python/MechanicalSoup')
-rw-r--r--dev-python/MechanicalSoup/Manifest1
-rw-r--r--dev-python/MechanicalSoup/MechanicalSoup-0.6.0.ebuild35
-rw-r--r--dev-python/MechanicalSoup/metadata.xml11
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/MechanicalSoup/Manifest b/dev-python/MechanicalSoup/Manifest
new file mode 100644
index 000000000000..8ae81527cf8d
--- /dev/null
+++ b/dev-python/MechanicalSoup/Manifest
@@ -0,0 +1 @@
+DIST MechanicalSoup-0.6.0.zip 5286 SHA256 e2b950c11fc5414d246b3c82024272d7ba729ab1f90534fc65fc445a63b7434d SHA512 cc413723514f3beee1267c57c16f6de2c19eb1f64535a60b546d289c7c18d8c4ba752ea61ab0b4a2aead2b56b12639cd226cb32662622515cb40262b7e619c24 WHIRLPOOL 8a36b65b234cecdec5e334d04fce8fcf8b306c205ae7b4b9acb815dc40db63ab3f7e0fc64ac4862295bfe3939a1eeaa189065f6bd57e1a158e2f4e1e168cb6f8
diff --git a/dev-python/MechanicalSoup/MechanicalSoup-0.6.0.ebuild b/dev-python/MechanicalSoup/MechanicalSoup-0.6.0.ebuild
new file mode 100644
index 000000000000..fdd6a82e41c2
--- /dev/null
+++ b/dev-python/MechanicalSoup/MechanicalSoup-0.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/hickford/MechanicalSoup"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="a python library for automating interaction with web sites"
+HOMEPAGE="https://pypi.python.org/pypi/MechanicalSoup"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-python/beautifulsoup-4.0
+ >=dev-python/requests-2.0
+ >=dev-python/six-1.4
+"
+DEPEND="
+${COMMON_DEPEND}
+app-arch/unzip
+ dev-python/setuptools
+"
+RDEPEND="${COMMON_DEPEND}"
diff --git a/dev-python/MechanicalSoup/metadata.xml b/dev-python/MechanicalSoup/metadata.xml
new file mode 100644
index 000000000000..b692da677470
--- /dev/null
+++ b/dev-python/MechanicalSoup/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>