summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-27 06:32:16 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-27 06:32:16 +0100
commit0bbeb3f0b31f3c9d8997c40c106847ee085add61 (patch)
treec4857ca731e7d8e3e777ecbbe64c1d16d036f64b /dev-python/Nuitka
parentdev-python/trimesh: Bump to 4.1.6 (diff)
downloadgentoo-0bbeb3f0b31f3c9d8997c40c106847ee085add61.tar.gz
gentoo-0bbeb3f0b31f3c9d8997c40c106847ee085add61.tar.bz2
gentoo-0bbeb3f0b31f3c9d8997c40c106847ee085add61.zip
dev-python/Nuitka: Bump to 2.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Nuitka')
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-2.0.5.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index edb41840f81c..e6002862e945 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1 +1,2 @@
DIST Nuitka-2.0.4.tar.gz 3932819 BLAKE2B 2e54e70848df30cc9f62e27ced44b356a4e817b9a21c8e8ec67a7432131cdc7d2f7bef9d3d1c26b47f34c906c2c6d7b84c10561515198b68fb3b63ed7de88fbf SHA512 b3ff3975ff3aeb1809e71bd8e8835a0d922ba26355e1e099d918df77a48976b625a3d47e0d0f99134292aee5dabaf34803448762b268aabad9cf1952440a64db
+DIST Nuitka-2.0.5.tar.gz 3932974 BLAKE2B 780a826774e480d5337fa541e58e841f3aa8b1f003ad1662bf614c967ebc612bd8214e3f58822c6c0583e813ca9c3492f863f48fa97927dbb7809e95d1379675 SHA512 4e4e4b5899a35bb0ce135b5141382b2a90a935f0ca43ab9cc44c9b3b3485684be2e2acbc1a050b343a4668eec17942a850a94eea1fbd8d46a2aa4586471e1224
diff --git a/dev-python/Nuitka/Nuitka-2.0.5.ebuild b/dev-python/Nuitka/Nuitka-2.0.5.ebuild
new file mode 100644
index 000000000000..123acd66de1f
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-2.0.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-build/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" dev-util/patchelf
+}