summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-06 17:39:17 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-06 18:45:50 +0100
commit80addf78059357c11ab36246d2508de7cad632c7 (patch)
treef2de808dae4465892a85aca7d2172837b9eb5b4b /dev-python/aiorpcX
parentapp-emulation/winetricks: Drop old (diff)
downloadgentoo-80addf78059357c11ab36246d2508de7cad632c7.tar.gz
gentoo-80addf78059357c11ab36246d2508de7cad632c7.tar.bz2
gentoo-80addf78059357c11ab36246d2508de7cad632c7.zip
dev-python/aiorpcX: Bump to 0.20.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiorpcX')
-rw-r--r--dev-python/aiorpcX/Manifest1
-rw-r--r--dev-python/aiorpcX/aiorpcX-0.20.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/aiorpcX/Manifest b/dev-python/aiorpcX/Manifest
index 5cc7d9fc31c1..96cba0911c1a 100644
--- a/dev-python/aiorpcX/Manifest
+++ b/dev-python/aiorpcX/Manifest
@@ -1,3 +1,4 @@
DIST aiorpcX-0.18.5.gh.tar.gz 65622 BLAKE2B 68b91e2cfb869c6971efb525fd35132c38ab9092362944fa77476bdb33f076f8415a079d97238e2c4ffbc6c9df596b468c2b6640389a11d1607b1a99aa8dc68d SHA512 5eb8417ce2ffb70208aec79e44ee0d8671c4cf86745f2d8061cf013c4ad17f83db68ed3ed43ef61df196e4ef073a21f9a4e22df46b00ce3054babf98dfcd1eaf
DIST aiorpcX-0.19.1.gh.tar.gz 72903 BLAKE2B ba3da1bc1f8d83ec6c6d2189aee554b4b819b601d366d0e8858ec73fe6aedddf6a6ed00d56d66c38d18ee44921a4cce7cb83ebf05aec9348355f88b8ed67e1a5 SHA512 b71edf335ad78b1d46b2b23dcb102b29f988d32f75571b881e2ce3471bf48c7ffc9bf509ce1cafec036662bb06d6f90598304c207f416b4124a7b02fdca915e8
DIST aiorpcX-0.19.gh.tar.gz 65557 BLAKE2B 2bc9d809abbcdcf4dd0358e4bb734068ef76482dc711e1c4568db78e9ae2141e00cffb82c1c7d5976887e0561b6c4f1422063969cec23a886bb192c279fc57d7 SHA512 21d8a75a90233bb4caed804da39274516a7c852c8adf9eabcba928ff7ad9bf922760fdca2c040aad8242193cb23be512803615973256b35347b6c998cccd6632
+DIST aiorpcX-0.20.1.gh.tar.gz 74087 BLAKE2B eee9b3d7d1e513e5eefec97ba30b8b5783b3128cd010b6c8c9530c19c06b1261499559249a9b46c2a8689daebd78d23f97a3b16c25572de80dc13a3650d4d593 SHA512 0f03fe54f268c64028607766bd45dd2fc8ee4ddab30da7744e9493e0e98cdbd9061dd502fd1bbde1880e5f4410f147f4ecf0ea04e4056c16bb784c3f76a558fc
diff --git a/dev-python/aiorpcX/aiorpcX-0.20.1.ebuild b/dev-python/aiorpcX/aiorpcX-0.20.1.ebuild
new file mode 100644
index 000000000000..89eb9710f38e
--- /dev/null
+++ b/dev-python/aiorpcX/aiorpcX-0.20.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic async RPC implementation, including JSON-RPC"
+HOMEPAGE="https://pypi.org/project/aiorpcX/
+ https://github.com/kyuupichan/aiorpcX/"
+SRC_URI="https://github.com/kyuupichan/aiorpcX/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # require Internet
+ tests/test_socks.py::TestSOCKSProxy::test_create_connection_resolve_good
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests failed with ${EPYTHON}"
+}