summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-26 01:43:19 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-26 02:01:40 +0100
commit261e10c33ab718ec4c509f0edeb611d48aaab609 (patch)
tree0c763c9e978fe1add41232eb8ddd543f126206e7 /dev-python/ansible-compat
parentdev-cpp/prometheus-cpp: drop 1.0.0 (diff)
downloadgentoo-261e10c33ab718ec4c509f0edeb611d48aaab609.tar.gz
gentoo-261e10c33ab718ec4c509f0edeb611d48aaab609.tar.bz2
gentoo-261e10c33ab718ec4c509f0edeb611d48aaab609.zip
dev-python/ansible-compat: drop 2.1.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest1
-rw-r--r--dev-python/ansible-compat/ansible-compat-2.1.0.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index c63286ee0e16..ffe6159bd51c 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1,3 +1,2 @@
-DIST ansible-compat-2.1.0.tar.gz 37840 BLAKE2B 5ac74cdaef1c932094996f331ed94418836b3351cbd376ae35ef22046b68dad0a8ab68fd293015db9954e0a5e1df4b5c529b3845cee5778daed2bb207733ca4f SHA512 a85681aff3d34ef4a4cdad8f419017a174bf315034495bc032a7e33d586cbcf72de74d163b6faf3cd21988704e5dbb922872b83a23981891311dbb18e53797a3
DIST ansible-compat-2.2.0.tar.gz 38772 BLAKE2B dbe74d23d2f2e4275bd9df2303417ea83517e780e65c6a34bd6ae1022be265ac816b50b309fc45f88e0c7fac7d7a22c83a826cc15be050698a6f35b267a36ac3 SHA512 3bd199431659ecba52743c6c985d2cdc6ee55396444241ba2456bc5430bbc87e26087dffbfff62ac341fa854e19baa0d7052cf79f20511222fd9e001dd020136
DIST ansible-compat-2.2.1.tar.gz 39126 BLAKE2B c4d0512606c99ba8f07e0287620c94af6b46d7bf0077f12dcbfd9689fc7106f164a87db25de1625249ac2930858bfa655bd93d83aba0d85ed4f8bdd42cd345dc SHA512 3e941eb2c5303f83b7e7c057d08801f192889b636d9c6e56a2ac21cf75144a52ba2916eaedeba7bf848dd268387bf4d3261541d75145b213cc3f6baca6a06e5e
diff --git a/dev-python/ansible-compat/ansible-compat-2.1.0.ebuild b/dev-python/ansible-compat/ansible-compat-2.1.0.ebuild
deleted file mode 100644
index 438acfa7dc99..000000000000
--- a/dev-python/ansible-compat/ansible-compat-2.1.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
-HOMEPAGE="
- https://pypi.org/project/ansible-compat/
- https://github.com/ansible/ansible-compat/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-
-RDEPEND="
- >=app-admin/ansible-core-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-4.5.1[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/subprocess-tee-0.3.5[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/setuptools_scm-6.3.1[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pytest-markdown[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-plus[${PYTHON_USEDEP}]
- )
-"
-
-# All these tests attempt to connect to galaxy.ansible.com
-EPYTEST_DESELECT=(
- test/test_runtime.py::test_install_collection
- test/test_runtime.py::test_install_collection_dest
- test/test_runtime.py::test_prepare_environment_with_collections
- test/test_runtime.py::test_prerun_reqs_v1
- test/test_runtime.py::test_prerun_reqs_v2
- test/test_runtime.py::test_require_collection_no_cache_dir
- test/test_runtime.py::test_require_collection_wrong_version
- test/test_runtime.py::test_require_collection
- test/test_runtime.py::test_upgrade_collection
- test/test_runtime_example.py::test_runtime
-)
-
-distutils_enable_sphinx docs \
- dev-python/ansible-pygments \
- dev-python/myst_parser \
- dev-python/sphinx_ansible_theme
-
-distutils_enable_tests pytest
-
-python_test() {
- epytest -p pytest_markdown.plugin
-}