summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/apipkg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/apipkg')
-rw-r--r--dev-python/apipkg/Manifest2
-rw-r--r--dev-python/apipkg/apipkg-1.2-r1.ebuild32
-rw-r--r--dev-python/apipkg/apipkg-1.4.ebuild30
-rw-r--r--dev-python/apipkg/metadata.xml8
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/apipkg/Manifest b/dev-python/apipkg/Manifest
new file mode 100644
index 000000000000..e2f8c92b4b59
--- /dev/null
+++ b/dev-python/apipkg/Manifest
@@ -0,0 +1,2 @@
+DIST apipkg-1.2.zip 12842 SHA256 ea86c4660e83015b6a3faad106cdf5a8d640688a93b84b93e8b64c60815789d4 SHA512 abd00a7c36914b9f79d5a54e1d0facc89fd6673f86d774784cd9a3a0e8e913cf3ef575914bcbbe4d17464b09e8b57d94c761453b2b19466e7dc408f321d22603 WHIRLPOOL 5693c8f1422d96e702eb929c2b3fe3f1a33b7d731ba4f6dced2b42229b941ca87848a31d19c2e79b0ce6fc0db98e24e6c81775c68374ca7f7bed59cf9682d049
+DIST apipkg-1.4.tar.gz 11224 SHA256 2e38399dbe842891fe85392601aab8f40a8f4cc5a9053c326de35a1cc0297ac6 SHA512 118f806706944513f50d3cdef596b32f8ce585cfaf94d2531a6d260f90a0e2147177161aaa6f5d6823150e6182d0f73be3dc01259b8a2f8d710733a22ea54789 WHIRLPOOL b0162094ee5209fb06727b5ad6d346e5738af9999f4fa21081cfedd4607d6025dd1d20621fe6c2e7801e5b405757987a6c0d63f698d74497401053847a9109bd
diff --git a/dev-python/apipkg/apipkg-1.2-r1.ebuild b/dev-python/apipkg/apipkg-1.2-r1.ebuild
new file mode 100644
index 000000000000..746d4450afd9
--- /dev/null
+++ b/dev-python/apipkg/apipkg-1.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="namespace control and lazy-import mechanism"
+HOMEPAGE="http://pypi.python.org/pypi/apipkg"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # https://bitbucket.org/hpk42/apipkg/issue/5/test-failure-with-python-34
+ sed -e 's:test_initpkg_not_transfers_not_existing_attrs:_&:' -i test_apipkg.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Bug 530388. The test requires patching to match py3.4; trivial.
+ py.test || die "Tests fail under ${EPYTHON}"
+}
diff --git a/dev-python/apipkg/apipkg-1.4.ebuild b/dev-python/apipkg/apipkg-1.4.ebuild
new file mode 100644
index 000000000000..b3ec9583c0e7
--- /dev/null
+++ b/dev-python/apipkg/apipkg-1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="namespace control and lazy-import mechanism"
+HOMEPAGE="http://pypi.python.org/pypi/apipkg"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/hgdistver[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test test_apipkg.py || die "Tests fail under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/apipkg/metadata.xml b/dev-python/apipkg/metadata.xml
new file mode 100644
index 000000000000..efc3b570c70c
--- /dev/null
+++ b/dev-python/apipkg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">apipkg</remote-id>
+ </upstream>
+</pkgmetadata>