summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-05-28 11:48:49 +0200
committerPacho Ramos <pacho@gentoo.org>2017-05-28 12:17:10 +0200
commitd6f0b6f926fc8c15a5ce5b14565a03d1104572e4 (patch)
treeb7a55bac386e399674cc63d57a8cc9e1fc637ac6 /dev-python/audioread/audioread-1.0.1-r1.ebuild
parentapp-forensics/foremost: Uncompress man page before using doman. (diff)
downloadgentoo-d6f0b6f926fc8c15a5ce5b14565a03d1104572e4.tar.gz
gentoo-d6f0b6f926fc8c15a5ce5b14565a03d1104572e4.tar.bz2
gentoo-d6f0b6f926fc8c15a5ce5b14565a03d1104572e4.zip
dev-python/audioread: Support newer python and drop obsolete gstreamer:0.10 dependency.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/audioread/audioread-1.0.1-r1.ebuild')
-rw-r--r--dev-python/audioread/audioread-1.0.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/audioread/audioread-1.0.1-r1.ebuild b/dev-python/audioread/audioread-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..5c8a480f88b7
--- /dev/null
+++ b/dev-python/audioread/audioread-1.0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for decoding audio files using whichever backend is available"
+HOMEPAGE="https://pypi.python.org/pypi/audioread"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="|| ( dev-python/pymad media-video/ffmpeg )"
+
+PATCHES=(
+ "${FILESDIR}/0001-Use-the-print-function-instead-of-the-print-keyword.patch"
+ )
+
+pkg_postinst() {
+ einfo "You might need to enable additional USE flags in backends to"
+ einfo "decode some types of audio files. Priority of backends:"
+ einfo " * mad"
+ einfo " * ffmpeg"
+}