summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-06 04:36:50 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-06 05:30:51 +0200
commite4728e50543089d5f66f0e659ccf995169a976dd (patch)
treea528774f244df16687ec3391fc49fed6c17034bd /dev-python/botocore
parentdev-python/passlib: enable py3.12 (diff)
downloadgentoo-e4728e50543089d5f66f0e659ccf995169a976dd.tar.gz
gentoo-e4728e50543089d5f66f0e659ccf995169a976dd.tar.bz2
gentoo-e4728e50543089d5f66f0e659ccf995169a976dd.zip
dev-python/botocore: Bump to 1.30.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.30.1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index c411f5056e46..9d1faded4a07 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.29.163.gh.tar.gz 11722194 BLAKE2B 2519b70cf7e5cba4e0544d7d1e520a
DIST botocore-1.29.164.gh.tar.gz 11728330 BLAKE2B 241747c505ae64941073de3b307829d443f79335ac2e8b756f00560b727e10d6b7ac65da92a4196ebc85fb2d266cf63a9e23fe89f3ecba8a90b13dd06a6f1a61 SHA512 181f715ea1357ed080e7bc6bfa5ea11a5a1d794721a38a32be834b703b503deae6b5bc2de25e9da541942347bbd53e4cd339eda7872e397fa90ecd0c5bdb72aa
DIST botocore-1.29.165.gh.tar.gz 11734461 BLAKE2B 30a479dfbc1e19c08baf38e5140a542bad0dab2fa7fc141103fc08deb6f5875a96b1d2c57ee2260d29f214f98a5a3b6c22ef811164e2f0a339515979c63835b2 SHA512 5ddff691727ec26b9af5158e6547b1641f345e017c087fea9829ea8dec250da805600467b9e27ee629dcd10db71f9adb88e562c3371674f6df71401c1b72c323
DIST botocore-1.30.0.gh.tar.gz 11743386 BLAKE2B 5117ae44f7b70dcf82e319fce1f72cba9291c7557144b410640b9ae727de0c4d31b7d896fd4d730b06a02f3ebd4341f208b84cc432a4aacf040b119ed2836923 SHA512 b1d3237949300e44eb29d3e4a14d3069cac75ad2da115d3c3e261605b7e9e7951402bf804b5055c33ce3e91a7c3c6b936ec4429e34f8b0d76ea61f1b804195c8
+DIST botocore-1.30.1.gh.tar.gz 11745235 BLAKE2B 07813b701ddde0e0ece703bb64abb9b0e8d15228f0db82756b4dc705ab97ebbfd10823cf1c279600d70a1e7caa15824cf34a108580b240c6a21d7760373f9e12 SHA512 4701b45541acbbe0d667c82db90f408bc50e28c4c8de0b6b90c8923ea8a159cf868b15eddbdaeac651ecc8f0829cff454723ba2f313a99f3878e818b0416ca64
diff --git a/dev-python/botocore/botocore-1.30.1.ebuild b/dev-python/botocore/botocore-1.30.1.ebuild
new file mode 100644
index 000000000000..3ced99abe4ff
--- /dev/null
+++ b/dev-python/botocore/botocore-1.30.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ # urllib3-2 compatibility, mock relies on implementation details
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_no_response_from_server
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_returned
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_sends_307
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_sends_connection_header
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_handles_expect_100_with_different_reason_phrase
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_state_reset_on_connection_close
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}