summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-23 06:47:58 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-23 07:35:41 +0200
commitffb8499bfad866a164612f149d473130decff100 (patch)
treeb6f0b1423d7be79c214bab9c591e406beaffcedb /dev-python/botocore
parentdev-util/ostree: respect CC w/ USE=introspection (diff)
downloadgentoo-ffb8499bfad866a164612f149d473130decff100.tar.gz
gentoo-ffb8499bfad866a164612f149d473130decff100.tar.bz2
gentoo-ffb8499bfad866a164612f149d473130decff100.zip
dev-python/botocore: Bump to 1.29.159
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.159.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 34a2c197bc96..81619045753f 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -8,3 +8,4 @@ DIST botocore-1.29.155.gh.tar.gz 11673165 BLAKE2B 653cc8b368d34502bcb16622677f11
DIST botocore-1.29.156.gh.tar.gz 11675796 BLAKE2B 683a26d0e19a9c567c68bd297bbe72c1319e2d7767e47f23fb51c9f5934fdfde69e15d86e86390198fe7c3fe1621129bf777c4d8a17e4a4c94c1ba160bb35b3a SHA512 93e6bd8878848c81d7e97706db7a456743c58372596ebf215e1a76f6b7b9a0ac75eefb1da5621d2cf21ff75184f9760fef0d67aeb076820ca8f0ba8ee6546e41
DIST botocore-1.29.157.gh.tar.gz 11678505 BLAKE2B f946118809c4d96000bc6cc23f650ea166d2dc52d0ffbd7eb5a6263feb81f0e102aa5083ff5562ec06ad6289045659234647fba6b2625e6b9d1b2204089f69fa SHA512 1bd7cf41979583b5ca6b956f7c4de7a63e19e3ce07b00d285f498c75b31dd640d0319416c9292cec41b7daf0b8a1c75e7859ba631d965e5ad746654f390d5ce1
DIST botocore-1.29.158.gh.tar.gz 11687611 BLAKE2B dde78cc51bde5e7f49054d5954ddaff190d2b26d5c156a3967fb10dd420ab9665bd6981c0a9ad05a358cc76ed51913bf544cd79d4a6e44cf993a81b7d3ab60dd SHA512 bf7523bfd888906f5a38b8789bbeddffc59fec9609d8bb173476e88e60b8fd036c26efdc3fa56fed1d23d69d09c1ee0f2b1e5ee946224cf3cb1435456098790c
+DIST botocore-1.29.159.gh.tar.gz 11694696 BLAKE2B 8643d3beb049b8ab153fda947801b862926f4160586d29831c0a1d6fef7e3caed2c2ff83bdffe1d61f49f81a11aa9dcc57b3c2d2419e21ccc543cc40a3532308 SHA512 782d051749f5a998cf93878e53b3f12e4fde36712708adff58f1e720e83f79f4330410725e0a8b097f5ca425cc093dfea8e746afedeceb582a3e82c7fd169477
diff --git a/dev-python/botocore/botocore-1.29.159.ebuild b/dev-python/botocore/botocore-1.29.159.ebuild
new file mode 100644
index 000000000000..3ced99abe4ff
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.159.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ # urllib3-2 compatibility, mock relies on implementation details
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_no_response_from_server
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_returned
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_sends_307
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_sends_connection_header
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_handles_expect_100_with_different_reason_phrase
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_state_reset_on_connection_close
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}