summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-16 15:02:41 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-16 15:37:38 +0100
commit165ef8fa44a7cb5ff3c246c68f44423b257cabaf (patch)
treed93e76361279eb4abd712204fff269c3ffafde7d /dev-python/bottle
parentdev-python/pytidylib: Use distutils_enable_tests (diff)
downloadgentoo-165ef8fa44a7cb5ff3c246c68f44423b257cabaf.tar.gz
gentoo-165ef8fa44a7cb5ff3c246c68f44423b257cabaf.tar.bz2
gentoo-165ef8fa44a7cb5ff3c246c68f44423b257cabaf.zip
dev-python/bottle: Replace python_gen_usedep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/bottle-0.12.16.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/bottle/bottle-0.12.16.ebuild b/dev-python/bottle/bottle-0.12.16.ebuild
index 529b10e1111e..4d5b75adc20f 100644
--- a/dev-python/bottle/bottle-0.12.16.ebuild
+++ b/dev-python/bottle/bottle-0.12.16.ebuild
@@ -18,7 +18,11 @@ IUSE="test"
RESTRICT="!test? ( test )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/mako[$(python_gen_usedep 'python*')] )"
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/mako[${PYTHON_USEDEP}]
+ ' 'python*')
+ )"
RDEPEND=""
PATCHES=(
@@ -36,7 +40,7 @@ python_prepare_all() {
python_test() {
# A few odd fails in the suite under pypy
# https://github.com/bottlepy/bottle/issues/714
- "${PYTHON}" test/testall.py || die "tests failed under ${EPYTHON}"
+ "${EPYTHON}" test/testall.py || die "tests failed under ${EPYTHON}"
}
pkg_postinst() {