summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2019-01-01 19:56:12 +0100
committerSebastian Pipping <sping@gentoo.org>2019-01-01 20:02:05 +0100
commit252e6c2f5e8f17e306bdc6e7da04102c3b926d02 (patch)
tree2f025c6c41ffa091cc81d466fab677c0e457c620 /dev-python/bottle
parentpackage.mask: mask app-misc/ckermit for removal (diff)
downloadgentoo-252e6c2f5e8f17e306bdc6e7da04102c3b926d02.tar.gz
gentoo-252e6c2f5e8f17e306bdc6e7da04102c3b926d02.tar.bz2
gentoo-252e6c2f5e8f17e306bdc6e7da04102c3b926d02.zip
dev-python/bottle: 0.12.16
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/Manifest1
-rw-r--r--dev-python/bottle/bottle-0.12.16.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/bottle/Manifest b/dev-python/bottle/Manifest
index afcba7d04ce8..a6843d959008 100644
--- a/dev-python/bottle/Manifest
+++ b/dev-python/bottle/Manifest
@@ -1,2 +1,3 @@
DIST bottle-0.12.12.tar.gz 71554 BLAKE2B 4b0d0d77c5ebaddcafd44e16a052535ded566245324d39e97a39dd20a193360487f9489e8e89471dd92ca35d6c5b2e8cbe1572a958db31b69d32d3e32f1b6403 SHA512 cdba3859129680f08b8c641708fd884ccf46d404786cbf48435d752fece998a446f49799e4e05e979b967843866f3e966a35a6cac7aed3270df55fae508bae31
DIST bottle-0.12.13.tar.gz 70870 BLAKE2B d8bdef473181ce1cf6c0d1ea3537c407e68d23c1c44ca33e26c647d3b3783040d466b594c56c10cdd007d23bdf1708412d3e3ff108effa9e8a92e1b22f7a6c69 SHA512 86d106eb08e0b736a85aa69871f2d1e23c1d6f71948b85718daf131002c53c000e092ffdfe5b36c60460473467a2ca2b5af19767344689ffe638245e6859a80b
+DIST bottle-0.12.16.tar.gz 72248 BLAKE2B 21b5bc376648baec74577ac5b57fcacc58899babe07a034a436d5e2bde75a9e2e48b2569c5caf1478e77790c5fa327114ab9b084f014cc1ba97637d9ddfec659 SHA512 3c167f95902522c8f264e8478403da8e9b8cd84594318c4a773d38b7548b5ba95c99ef922033f6885cdc044b31f9c2e2f7ed263886637ce2a048e99c0c6e1403
diff --git a/dev-python/bottle/bottle-0.12.16.ebuild b/dev-python/bottle/bottle-0.12.16.ebuild
new file mode 100644
index 000000000000..db42adc4ec38
--- /dev/null
+++ b/dev-python/bottle/bottle-0.12.16.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="https://pypi.org/project/bottle/ http://bottlepy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mako[$(python_gen_usedep 'python*')] )"
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.8-py3.5-backport.patch
+)
+
+python_prepare_all() {
+ sed -i -e '/scripts/d' setup.py || die
+
+ # Remove test file requring connection to network
+ rm test/test_server.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # A few odd fails in the suite under pypy
+ # https://github.com/bottlepy/bottle/issues/714
+ "${PYTHON}" test/testall.py || die "tests failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Templating support" dev-python/mako
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}