summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2019-12-27 20:52:36 +0100
committerSebastian Pipping <sping@gentoo.org>2019-12-27 20:54:26 +0100
commitbd613b5ea4d2cb2c78a083710221490cfd5bb081 (patch)
treebdf28def6d45ad13f40622629a7bb42ac6b0f948 /dev-python/bottle
parentapp-shells/mcfly: drop ~ppc64 keyword (diff)
downloadgentoo-bd613b5ea4d2cb2c78a083710221490cfd5bb081.tar.gz
gentoo-bd613b5ea4d2cb2c78a083710221490cfd5bb081.tar.bz2
gentoo-bd613b5ea4d2cb2c78a083710221490cfd5bb081.zip
dev-python/bottle: 0.12.18 + EAPI 7 + Python 3.8
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.83, Repoman-2.3.20
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/Manifest1
-rw-r--r--dev-python/bottle/bottle-0.12.18.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/bottle/Manifest b/dev-python/bottle/Manifest
index a6843d959008..56153c75cb9a 100644
--- a/dev-python/bottle/Manifest
+++ b/dev-python/bottle/Manifest
@@ -1,3 +1,4 @@
DIST bottle-0.12.12.tar.gz 71554 BLAKE2B 4b0d0d77c5ebaddcafd44e16a052535ded566245324d39e97a39dd20a193360487f9489e8e89471dd92ca35d6c5b2e8cbe1572a958db31b69d32d3e32f1b6403 SHA512 cdba3859129680f08b8c641708fd884ccf46d404786cbf48435d752fece998a446f49799e4e05e979b967843866f3e966a35a6cac7aed3270df55fae508bae31
DIST bottle-0.12.13.tar.gz 70870 BLAKE2B d8bdef473181ce1cf6c0d1ea3537c407e68d23c1c44ca33e26c647d3b3783040d466b594c56c10cdd007d23bdf1708412d3e3ff108effa9e8a92e1b22f7a6c69 SHA512 86d106eb08e0b736a85aa69871f2d1e23c1d6f71948b85718daf131002c53c000e092ffdfe5b36c60460473467a2ca2b5af19767344689ffe638245e6859a80b
DIST bottle-0.12.16.tar.gz 72248 BLAKE2B 21b5bc376648baec74577ac5b57fcacc58899babe07a034a436d5e2bde75a9e2e48b2569c5caf1478e77790c5fa327114ab9b084f014cc1ba97637d9ddfec659 SHA512 3c167f95902522c8f264e8478403da8e9b8cd84594318c4a773d38b7548b5ba95c99ef922033f6885cdc044b31f9c2e2f7ed263886637ce2a048e99c0c6e1403
+DIST bottle-0.12.18.tar.gz 71557 BLAKE2B a34cc1ab9a2a8505b7fda8bbddbae30b4e6c4829cae53f0f886237a21fdfa7f2b2463b216d7a16464539f41bdce4c1dabb5cc66027b8fdd19b10e9a78a3cdbb5 SHA512 db8a341cd80d755205518bb9eac5b79dca9e541ab3ad9d9d57f891d895f7df75a8facd16b068cbdf7c4f884f35e384449f4cbd565a43e9c5d000d3a9f5b7dcb0
diff --git a/dev-python/bottle/bottle-0.12.18.ebuild b/dev-python/bottle/bottle-0.12.18.ebuild
new file mode 100644
index 000000000000..6741fdd076c8
--- /dev/null
+++ b/dev-python/bottle/bottle-0.12.18.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="https://pypi.org/project/bottle/ https://bottlepy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/mako[${PYTHON_USEDEP}]
+ ' 'python*')
+ )"
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.8-py3.5-backport.patch
+)
+
+python_prepare_all() {
+ sed -i -e '/scripts/d' setup.py || die
+
+ # Remove test file requring connection to network
+ rm test/test_server.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # A few odd fails in the suite under pypy
+ # https://github.com/bottlepy/bottle/issues/714
+ "${EPYTHON}" test/testall.py || die "tests failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Templating support" dev-python/mako
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}