summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-11 09:50:15 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-11 09:53:27 +0200
commitbe460e6fc2601ee65e69326a4f792a8d0453af99 (patch)
tree5a826454bad560b6463a2b1e7587360296c626e4 /dev-python/carbon
parentdev-python/bert: Remove old (diff)
downloadgentoo-be460e6fc2601ee65e69326a4f792a8d0453af99.tar.gz
gentoo-be460e6fc2601ee65e69326a4f792a8d0453af99.tar.bz2
gentoo-be460e6fc2601ee65e69326a4f792a8d0453af99.zip
dev-python/carbon: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/carbon')
-rw-r--r--dev-python/carbon/carbon-1.1.8.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/carbon/carbon-1.1.8.ebuild b/dev-python/carbon/carbon-1.1.8.ebuild
deleted file mode 100644
index ae7b292a9cd4..000000000000
--- a/dev-python/carbon/carbon-1.1.8.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit distutils-r1
-
-DESCRIPTION="Backend data caching and persistence daemon for Graphite"
-HOMEPAGE="https://graphiteapp.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86"
-
-# whisper appears to have been missed from listing in install_requires in setup.py
-RDEPEND="
- dev-python/twisted[${PYTHON_USEDEP}]
- dev-python/cachetools[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- =dev-python/whisper-${PV}*[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # Do not install the configuration and data files. We install them
- # somewhere sensible by hand.
- sed -i -e '/data_files=install_files,/d' setup.py || die
- # We want FHS-style paths instead of /opt/graphite
- export GRAPHITE_NO_PREFIX=yes
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /etc/carbon
- doins conf/*
-
- keepdir /var/log/carbon /var/lib/carbon/{whisper,lists,rrd}
-
- newinitd "${FILESDIR}"/carbon.initd2 carbon-cache
- newinitd "${FILESDIR}"/carbon.initd2 carbon-relay
- newinitd "${FILESDIR}"/carbon.initd2 carbon-aggregator
-
- newconfd "${FILESDIR}"/carbon.confd carbon-cache
- newconfd "${FILESDIR}"/carbon.confd carbon-relay
- newconfd "${FILESDIR}"/carbon.confd carbon-aggregator
-}
-
-pkg_postinst() {
- einfo 'This ebuild installs carbon into FHS-style paths.'
- einfo 'You will probably have to set GRAPHITE_CONF_DIR to /etc/carbon'
- einfo 'and GRAPHITE_STORAGE_DIR to /var/lib/carbon to make use of this'
- einfo '(see /etc/carbon/carbon.conf.example).'
- einfo ' '
- einfo 'OpenRC init script supports multiple instances !'
- einfo 'Example to run an instance b of carbon-cache :'
- einfo ' ln -s /etc/init.d/carbon-cache /etc/init.d/carbon-cache.b'
- einfo ' cp /etc/conf.d/carbon-cache /etc/conf.d/carbon-cache.b'
-}