summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gmail.com>2021-08-02 20:59:50 +0300
committerMichał Górny <mgorny@gentoo.org>2021-08-05 20:07:16 +0200
commitb5d2f62890c13559a006fbaac56a0c4530b1f07d (patch)
tree7693179eeec82c1cf1db30cd2be534c124d33d05 /dev-python/cheetah3
parentdev-python/libcloud: enable py3.10, add dep dev-python/pyopenssl (diff)
downloadgentoo-b5d2f62890c13559a006fbaac56a0c4530b1f07d.tar.gz
gentoo-b5d2f62890c13559a006fbaac56a0c4530b1f07d.tar.bz2
gentoo-b5d2f62890c13559a006fbaac56a0c4530b1f07d.zip
dev-python/cheetah3: enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cheetah3')
-rw-r--r--dev-python/cheetah3/cheetah3-3.2.6.ebuild8
-rw-r--r--dev-python/cheetah3/files/cheetah3-3.2.6-fix-py3.10-tests.patch27
2 files changed, 33 insertions, 2 deletions
diff --git a/dev-python/cheetah3/cheetah3-3.2.6.ebuild b/dev-python/cheetah3/cheetah3-3.2.6.ebuild
index 750ee0a37321..c4cb900671de 100644
--- a/dev-python/cheetah3/cheetah3-3.2.6.ebuild
+++ b/dev-python/cheetah3/cheetah3-3.2.6.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Python-powered template engine and code generator"
@@ -22,6 +22,10 @@ BDEPEND="${RDEPEND}"
DOCS=( ANNOUNCE.rst README.rst TODO )
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10-tests.patch"
+)
+
python_prepare_all() {
# Disable broken tests.
sed \
diff --git a/dev-python/cheetah3/files/cheetah3-3.2.6-fix-py3.10-tests.patch b/dev-python/cheetah3/files/cheetah3-3.2.6-fix-py3.10-tests.patch
new file mode 100644
index 000000000000..845520fb02ad
--- /dev/null
+++ b/dev-python/cheetah3/files/cheetah3-3.2.6-fix-py3.10-tests.patch
@@ -0,0 +1,27 @@
+From 112dddd8fa5fb9c285fb8ef2818abfef99365070 Mon Sep 17 00:00:00 2001
+From: Victor Stinner <vstinner@python.org>
+Date: Tue, 19 Jan 2021 11:19:15 +0100
+Subject: [PATCH] Skip test_import_bootlocale() on Python 3.10
+
+The _bootlocale module has been removed from Python 3.10:
+https://github.com/python/cpython/commit/b62bdf71ea0cd52041d49691d8ae3dc645bd48e1
+https://bugs.python.org/issue42208
+---
+ Cheetah/Tests/ImportHooks.py | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/Cheetah/Tests/ImportHooks.py b/Cheetah/Tests/ImportHooks.py
+index d7b5f5d..bc0239c 100644
+--- a/Cheetah/Tests/ImportHooks.py
++++ b/Cheetah/Tests/ImportHooks.py
+@@ -87,7 +87,9 @@ def test_import_builtin(self):
+ return
+ raise self.fail("All builtin modules are imported")
+
+- if not PY2:
++ # _bootlocale was removed in Python 3.10:
++ # https://bugs.python.org/issue42208
++ if not PY2 and sys.version_info < (3, 10):
+ def test_import_bootlocale(self):
+ if '_bootlocale' in sys.modules:
+ del sys.modules['_bootlocale']