summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-27 11:36:35 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-27 15:09:28 +0100
commitba5c3fc6b82ad2deb23729abb3e955fa4b4de651 (patch)
tree724ec5b1e29a27ac50d070ef10730d4cd5a1e5aa /dev-python/click
parentmedia-sound/csound: drop old (diff)
downloadgentoo-ba5c3fc6b82ad2deb23729abb3e955fa4b4de651.tar.gz
gentoo-ba5c3fc6b82ad2deb23729abb3e955fa4b4de651.tar.bz2
gentoo-ba5c3fc6b82ad2deb23729abb3e955fa4b4de651.zip
dev-python/click: Version Bump
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/Manifest1
-rw-r--r--dev-python/click/click-6.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/click/Manifest b/dev-python/click/Manifest
index 2d1ffe2cf5da..c1372b3b9a20 100644
--- a/dev-python/click/Manifest
+++ b/dev-python/click/Manifest
@@ -1,2 +1,3 @@
DIST click-2.0.tar.gz 47342 SHA256 33a984fe73aa8c6bf69c38098b69dd38405529db54baf4c8cf64c50b2dee644f SHA512 4c703ab4b5c76e393420b0edf9af9e8ddb301ccfef5f8117d3408eaa8a94abe6b7b5c7a8b61b7774a3b459b153c10438e8934f21ceb73697199828cce2c2887c WHIRLPOOL bf599395245319b31c189df297a1ec35ca69723ed24e2d3e9aa9231a3cfebdb80e1f43a0b010865b6fbecf09f23dc1121cca232aec26f09bdb455f41da5261c4
DIST click-5.1.tar.gz 275592 SHA256 678c98275431fad324275dec63791e4a17558b40e5a110e20a82866139a85a5a SHA512 b860b0227644f5d1cc24d41e66985421ec971f11f3f596fb46508fdc787200b949e7ef29b2035421ebb0115384688da03c3c95a0d6acc58dd3b566b32a2b7c6a WHIRLPOOL 8bda8de886a272972595bf51af3881962063daaa4fc9e104af59b4798008a2f780c3fb4a758d7fe14ef075b92aecc43415b08bb213cbd6ac4ab92a56e405276e
+DIST click-6.0.tar.gz 281589 SHA256 3972ee95a32181e9069040414dd7c77001e9404c3c4d295300cdca06a8db026d SHA512 c1a7c5c2a28c63acea54c481bc57630c145d087c9272fb39563b35df7ac138c3b9e58dfefbd084fe3490c5c8868361054f4ef79c61c921df93e00246f703e29b WHIRLPOOL dd64ace594cd17870660ab7650876f519fd75429397bd52f8f727b2126dd81dd00e7eec65e5891f71b891b3a59dc29f0339a8b50aa514dc0eb26fbac6c337518
diff --git a/dev-python/click/click-6.0.ebuild b/dev-python/click/click-6.0.ebuild
new file mode 100644
index 000000000000..b0aa96c7e1c2
--- /dev/null
+++ b/dev-python/click/click-6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://click.pocoo.org/ https://pypi.python.org/pypi/click"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}