summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-10-13 16:21:44 -0400
committerCraig Andrews <candrews@gentoo.org>2019-10-13 16:23:14 -0400
commit0bc42236f0128b77c4453df26693ad69ec008cd0 (patch)
tree30414a0b2d5300353e3bfacd02608f3c511edd9b /dev-python/clint
parentdev-python/clint: Python 3.7 compatibility (diff)
downloadgentoo-0bc42236f0128b77c4453df26693ad69ec008cd0.tar.gz
gentoo-0bc42236f0128b77c4453df26693ad69ec008cd0.tar.bz2
gentoo-0bc42236f0128b77c4453df26693ad69ec008cd0.zip
dev-python/clint: EAPI=7
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-python/clint')
-rw-r--r--dev-python/clint/clint-0.5.1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/clint/clint-0.5.1-r1.ebuild b/dev-python/clint/clint-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..f416abd9d86e
--- /dev/null
+++ b/dev-python/clint/clint-0.5.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python Command-line Application Tools"
+HOMEPAGE="https://github.com/kennethreitz/clint"
+SRC_URI="https://github.com/kennethreitz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="dev-python/args[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ distutils-r1_python_install_all
+}