summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/cov-core
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/cov-core')
-rw-r--r--dev-python/cov-core/Manifest2
-rw-r--r--dev-python/cov-core/cov-core-1.15.0.ebuild20
-rw-r--r--dev-python/cov-core/cov-core-1.7.ebuild20
-rw-r--r--dev-python/cov-core/metadata.xml12
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/cov-core/Manifest b/dev-python/cov-core/Manifest
new file mode 100644
index 000000000000..0183413ce92a
--- /dev/null
+++ b/dev-python/cov-core/Manifest
@@ -0,0 +1,2 @@
+DIST cov-core-1.15.0.tar.gz 5890 SHA256 4a14c67d520fda9d42b0da6134638578caae1d374b9bb462d8de00587dba764c SHA512 1b962a6a7253c1f6530248f3a71058e7709ee5cca274166807f040163c9cc240e9e85e42820063476c1c0f6dfca81d45277738663ed818fe715b30db151ace16 WHIRLPOOL 8a4198b8914507aeeb44c66ece4397c98c86cb7a5206d5b69cfea34bda2399f6c37ad46935839a86edadafecbf534dbe8a275801f9b217e994576f399f0a884a
+DIST cov-core-1.7.tar.gz 5972 SHA256 8050c226fa73234b88e62630d64e0416c879202891309cbcdbb8b556222c3020 SHA512 8e1744f686262c5affc6e2d7b08ce6277b60e79156a4c2491f805325048702f765b64c40acd53d59b5fd7358d85bf3ab367270eef4a12ad209db5f661612b140 WHIRLPOOL cb85a234560bae9628853958a88e15abb85a570710fdfaf627b1a3c0242bf3d6b46bdecd14972744df5331d884c1b592266143f4ececa0b795fb4a682d1156a6
diff --git a/dev-python/cov-core/cov-core-1.15.0.ebuild b/dev-python/cov-core/cov-core-1.15.0.ebuild
new file mode 100644
index 000000000000..446ea79b0f56
--- /dev/null
+++ b/dev-python/cov-core/cov-core-1.15.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="plugin core for use by pytest-cov, nose-cov and nose2-cov"
+HOMEPAGE="https://bitbucket.org/memedough/cov-core/overview"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~hppa ia64 m68k ppc ppc64 s390 sh x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-python/coverage-3.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/cov-core/cov-core-1.7.ebuild b/dev-python/cov-core/cov-core-1.7.ebuild
new file mode 100644
index 000000000000..bb61f48abc9c
--- /dev/null
+++ b/dev-python/cov-core/cov-core-1.7.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{3,4}} pypy pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="plugin core for use by pytest-cov, nose-cov and nose2-cov"
+HOMEPAGE="https://bitbucket.org/memedough/cov-core/overview"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha ~amd64 arm hppa ~ppc ~ppc64 sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/coverage[${PYTHON_USEDEP}]"
+DEPEND=""
diff --git a/dev-python/cov-core/metadata.xml b/dev-python/cov-core/metadata.xml
new file mode 100644
index 000000000000..9e8e0d2961c4
--- /dev/null
+++ b/dev-python/cov-core/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">cov-core</remote-id>
+ <remote-id type="bitbucket">memedough/cov-core</remote-id>
+ </upstream>
+</pkgmetadata>