summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 13:22:01 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 13:35:08 +0100
commitf25e0ee7b9e533454b70fde9933bcd1638a103c5 (patch)
tree49fbaa8a2ec21be59540a78ecdd17515a35559c5 /dev-python/crcmod
parentdev-python/configobj: Switch to PEP 517 build (diff)
downloadgentoo-f25e0ee7b9e533454b70fde9933bcd1638a103c5.tar.gz
gentoo-f25e0ee7b9e533454b70fde9933bcd1638a103c5.tar.bz2
gentoo-f25e0ee7b9e533454b70fde9933bcd1638a103c5.zip
dev-python/crcmod: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/crcmod')
-rw-r--r--dev-python/crcmod/crcmod-1.7-r5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/crcmod/crcmod-1.7-r5.ebuild b/dev-python/crcmod/crcmod-1.7-r5.ebuild
new file mode 100644
index 000000000000..0dbac02cd773
--- /dev/null
+++ b/dev-python/crcmod/crcmod-1.7-r5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python CRC Generator module"
+HOMEPAGE="http://crcmod.sourceforge.net/"
+SRC_URI="mirror://sourceforge/crcmod/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DOCS=( changelog test/examples.py )
+
+python_test() {
+ "${EPYTHON}" test/test_crcmod.py -v || die "Tests fail with ${EPYTHON}"
+}