summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-12 19:38:16 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-12 19:38:23 +0100
commit1c062f8d8b341686e1c6f4aa00702c456d3ea69d (patch)
tree6a0a9f6a0c76dd8e73b51c01b6d2f3a0e617de21 /dev-python/cryptography
parentdev-python/pip: Move to virtual for modules with mixed support (diff)
downloadgentoo-1c062f8d8b341686e1c6f4aa00702c456d3ea69d.tar.gz
gentoo-1c062f8d8b341686e1c6f4aa00702c456d3ea69d.tar.bz2
gentoo-1c062f8d8b341686e1c6f4aa00702c456d3ea69d.zip
dev-python/cryptography: Move to virtual for modules with mixed support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/cryptography')
-rw-r--r--dev-python/cryptography/cryptography-1.0.2.ebuild2
-rw-r--r--dev-python/cryptography/cryptography-1.1.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/cryptography/cryptography-1.0.2.ebuild b/dev-python/cryptography/cryptography-1.0.2.ebuild
index 0d097ad72b1f..20bb286d1d60 100644
--- a/dev-python/cryptography/cryptography-1.0.2.ebuild
+++ b/dev-python/cryptography/cryptography-1.0.2.ebuild
@@ -25,11 +25,11 @@ RDEPEND="
$(python_gen_cond_dep '>=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]' 'python*')
$(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy)
>=dev-python/idna-2.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/ipaddress[${PYTHON_USEDEP}]' python2_7 pypy)
>=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
diff --git a/dev-python/cryptography/cryptography-1.1.ebuild b/dev-python/cryptography/cryptography-1.1.ebuild
index e0699eb7decb..eff2cad13228 100644
--- a/dev-python/cryptography/cryptography-1.1.ebuild
+++ b/dev-python/cryptography/cryptography-1.1.ebuild
@@ -24,11 +24,11 @@ RDEPEND="
$(python_gen_cond_dep '>=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]' 'python*')
$(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy)
>=dev-python/idna-2.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/ipaddress[${PYTHON_USEDEP}]' python2_7 pypy)
>=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.4.1[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]