summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-02-15 00:48:47 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-02-15 00:48:47 +0100
commit7517af4879a0a107b7f33a30472e4ff3ef23bd9e (patch)
tree578030522a74a565565c33567e5b692892b87c7b /dev-python/dbus-python
parentdev-libs/dbus-glib: Version bump to 0.110 (diff)
downloadgentoo-7517af4879a0a107b7f33a30472e4ff3ef23bd9e.tar.gz
gentoo-7517af4879a0a107b7f33a30472e4ff3ef23bd9e.tar.bz2
gentoo-7517af4879a0a107b7f33a30472e4ff3ef23bd9e.zip
dev-python/dbus-python: Version bump to 1.2.6
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/Manifest1
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.6.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/dbus-python/Manifest b/dev-python/dbus-python/Manifest
index 53726f31b9a3..88af6bd69231 100644
--- a/dev-python/dbus-python/Manifest
+++ b/dev-python/dbus-python/Manifest
@@ -1,2 +1,3 @@
DIST dbus-python-1.2.0.tar.gz 602426 BLAKE2B 86f5ba9283256b83d268ff7c27368e587896d58f87b15aefe9d29a90530ced591a2c6814dd37b91274910ed131fe031846071311bc6cc07c11d1f9cdda9e4602 SHA512 013b23e08fa1ed43f53a756587fefbc9770f7c51e93510e555acbd77230b7200693419bba9a69680d790bbaf123f4a195afa38b3eee1143da950fee0b5130bce
DIST dbus-python-1.2.4.tar.gz 612112 BLAKE2B cccd3e2f5d700c0d228e7d21fd85e2307357778371742a7fe26a0e419af41886efebb27a73f642d2ecd4603c79f4afe6e7002af95c831180e0e7844c079b2c8c SHA512 efdd9d96a8b56e813c93208d34777f1ca2db96c076d31f13afbcaec3c7770a16a623d5531fe23443130c555240949802503f171f2064d45eee97546d6251304b
+DIST dbus-python-1.2.6.tar.gz 778893 BLAKE2B 1587bc9b1795e5c416397468b2061c869d923aea0983e604862342b27d37b946b1fcdd3bf07a612dba30087bdc6a5fa734906188c55756edf38d50eb67b7eef6 SHA512 6f2aec81defd2528d9876ec9a83843f8767275a5d6cf1b2b7b7a094f892f552f9a7b3d7b5006465254d410e503108e10138d7dd4cb3f1a4035d7f8d58c4d0684
diff --git a/dev-python/dbus-python/dbus-python-1.2.6.ebuild b/dev-python/dbus-python/dbus-python-1.2.6.ebuild
new file mode 100644
index 000000000000..169ee6c62d28
--- /dev/null
+++ b/dev-python/dbus-python/dbus-python-1.2.6.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit autotools eutils python-r1
+
+DESCRIPTION="Python bindings for the D-Bus messagebus"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/DBusBindings https://dbus.freedesktop.org/doc/dbus-python/"
+SRC_URI="https://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~m68k-mint"
+IUSE="doc examples test"
+# API docs generated with epydoc, which is python2-only
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ doc? ( python_targets_python2_7 )"
+
+RDEPEND="
+ >=dev-libs/dbus-glib-0.108:=
+ >=sys-apps/dbus-1.8:=
+ >=dev-libs/glib-2.40
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ dev-python/docutils[python_targets_python2_7?]
+ =dev-python/epydoc-3*[python_targets_python2_7?] )
+ test? ( dev-python/pygobject:3[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ default
+ # Update py-compile, bug 529502.
+ eautoreconf
+ python_copy_sources
+}
+
+src_configure() {
+ configuring() {
+ local PYTHON_CONFIG
+ python_export PYTHON_CONFIG
+
+ # epydoc is python2-only, bug #447642
+ local apidocs=--disable-api-docs
+ [[ ${EPYTHON/.*} = "python2" ]] && apidocs=$(use_enable doc api-docs)
+
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --disable-html-docs \
+ ${apidocs} \
+ PYTHON_INCLUDES="$(${PYTHON_CONFIG} --includes)" \
+ PYTHON_LIBS="$(${PYTHON_CONFIG} --ldflags)"
+ # configure assumes that ${PYTHON}-config executable exists :/
+ }
+ python_foreach_impl run_in_build_dir configuring
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installing() {
+ default
+ [[ ${EPYTHON/.*} = "python2" ]] && use doc && dohtml -r api/*
+ }
+ python_foreach_impl run_in_build_dir installing
+ prune_libtool_files --modules
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+run_in_build_dir() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "$@"
+ popd > /dev/null
+}