summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-30 20:49:29 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-30 21:26:32 +0100
commit085a5e073d0c819afb5061e102f9fae28ffaae8c (patch)
treef27ff87f7cbb61f36be6720c57274cc8372ab5cb /dev-python/django-cors-headers
parentdev-python/django-cacheops: drop old version (diff)
downloadgentoo-085a5e073d0c819afb5061e102f9fae28ffaae8c.tar.gz
gentoo-085a5e073d0c819afb5061e102f9fae28ffaae8c.tar.bz2
gentoo-085a5e073d0c819afb5061e102f9fae28ffaae8c.zip
dev-python/django-cors-headers: bump to version 3.7.0
Also added python3_9 support. Closes: https://bugs.gentoo.org/766995 Closes: https://bugs.gentoo.org/767190 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python/django-cors-headers')
-rw-r--r--dev-python/django-cors-headers/Manifest1
-rw-r--r--dev-python/django-cors-headers/django-cors-headers-3.7.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/django-cors-headers/Manifest b/dev-python/django-cors-headers/Manifest
index 91d7fa3a2623..06c983d8f000 100644
--- a/dev-python/django-cors-headers/Manifest
+++ b/dev-python/django-cors-headers/Manifest
@@ -1 +1,2 @@
DIST django-cors-headers-3.2.1.tar.gz 26261 BLAKE2B fcab223308223af20754275256e9c03f2dc99210b05d200fcfa0f0e4583c7f8a098ec66a3a40d771aa94221d9d21d2bb0c673f4722b72f598b95f31420fa7526 SHA512 9b48820fed88a468ea51db9ed7a8506afe96ebefcde3c1e2fc497a6580aa506669bec7bbdc87957e9d9e8b711445a7d1359a213a6a15dfcb7313d1437e252397
+DIST django-cors-headers-3.7.0.tar.gz 88367 BLAKE2B d8a41a605d4823852cce65ffa8005d1e82598cdd81702d1ecef304c2a117dc553447c0cc7e9c31641165f0ba6975b757365733b349c0f5b1f4e9964095b918c2 SHA512 e1dc9695f99108f0908d8d348d284f1fd4a8ccbb84b3c748c9ae8d81d6f32ac8ef3417b612710e64ea4c63d464d97ac31a199292ebcdaaec3f3e37ad025ed0de
diff --git a/dev-python/django-cors-headers/django-cors-headers-3.7.0.ebuild b/dev-python/django-cors-headers/django-cors-headers-3.7.0.ebuild
new file mode 100644
index 000000000000..eecd52c04404
--- /dev/null
+++ b/dev-python/django-cors-headers/django-cors-headers-3.7.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Django App that adds CORS (Cross-Origin Resource Sharing) headers to responses"
+HOMEPAGE="https://github.com/adamchainz/django-cors-headers"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+# Tests need a configured database
+RESTRICT="test"
+
+RDEPEND=">=dev-python/django-1.11[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest