summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-30 23:36:22 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-30 23:38:04 +0200
commit475f333b4e6209431849b4b0d020a0e870f79a17 (patch)
tree813d41937fdf88901a5d2195b20348ae91c5a51e /dev-python/django-sortedm2m
parentdev-python/cachetools: Bump to 4.2.4 (diff)
downloadgentoo-475f333b4e6209431849b4b0d020a0e870f79a17.tar.gz
gentoo-475f333b4e6209431849b4b0d020a0e870f79a17.tar.bz2
gentoo-475f333b4e6209431849b4b0d020a0e870f79a17.zip
dev-python/django-sortedm2m: Bump to 3.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-sortedm2m')
-rw-r--r--dev-python/django-sortedm2m/Manifest1
-rw-r--r--dev-python/django-sortedm2m/django-sortedm2m-3.1.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/django-sortedm2m/Manifest b/dev-python/django-sortedm2m/Manifest
index f4e75b5234e0..8fbaab22e0a6 100644
--- a/dev-python/django-sortedm2m/Manifest
+++ b/dev-python/django-sortedm2m/Manifest
@@ -1 +1,2 @@
DIST django-sortedm2m-3.0.2.gh.tar.gz 44296 BLAKE2B 41dd4a7bc654fef638f7a387b1307ee32ca2d8733f4ba6b9fffc92a9ab4c6af7d64159cd5a24f4305483502609a1730fe12a3072f493251840ba840b98155877 SHA512 4e58ff37cdd798d88c47a8efee2bc783ad7109b30e023127345b6d12b176e452d6125fbcaba5392fc11660df3e8b66be4b23d5ff7ab90020f946cfedc80276a7
+DIST django-sortedm2m-3.1.1.gh.tar.gz 45888 BLAKE2B 878a23d5f5dad114b0b6ef9bd687d4e23620c823a8ad33a66b7c6c1e598db15e5328a46373dd6d7fd9449b4ba533e21664db716cde40150af2451a74f2f28fda SHA512 440c049a1fbe54c0db8edb0a5a737b5d84553afb7305d21a64c2dbac02f143e6f17e7e0499a4d3e687b13f292558d7818c030d78d8cc9443048a95ae6b50204f
diff --git a/dev-python/django-sortedm2m/django-sortedm2m-3.1.1.ebuild b/dev-python/django-sortedm2m/django-sortedm2m-3.1.1.ebuild
new file mode 100644
index 000000000000..462523bd30b5
--- /dev/null
+++ b/dev-python/django-sortedm2m/django-sortedm2m-3.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Drop-in replacement for django's many to many field with sorted relations"
+HOMEPAGE="https://pypi.org/project/django-sortedm2m/
+ https://github.com/jazzband/django-sortedm2m"
+SRC_URI="
+ https://github.com/jazzband/django-sortedm2m/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ )"
+
+python_test() {
+ local -x PYTHONPATH=test_project:${PYTHONPATH}
+ local -x DB_ENGINE=sqlite3
+ local -x DB_NAME=":memory:"
+ django-admin test -v 2 --settings=settings --noinput sortedm2m_tests ||
+ die "Tests fail with ${EPYTHON}"
+}