summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2016-04-14 12:30:07 +0800
committerIan Delaney <idella4@gentoo.org>2016-04-14 12:47:42 +0800
commitbb5bf685f43b0cfb249de81ac14b760f73de3b2f (patch)
tree5c345188fe165499b6624732a89060492ba2e417 /dev-python/django-tastypie
parentdev-python/biplist: add py3.5 support to vn. 1.0.1, bump to EAPI 6 (diff)
downloadgentoo-bb5bf685f43b0cfb249de81ac14b760f73de3b2f.tar.gz
gentoo-bb5bf685f43b0cfb249de81ac14b760f73de3b2f.tar.bz2
gentoo-bb5bf685f43b0cfb249de81ac14b760f73de3b2f.zip
dev-python/django-tastypie: bump to vn 0.13.3
removed 3 use flags found to be un-needed. Test phase still set to RESTRICT since it is not ready to run in this tarball provided. Request made from Gentoo-bug: #578604 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/django-tastypie')
-rw-r--r--dev-python/django-tastypie/Manifest1
-rw-r--r--dev-python/django-tastypie/django-tastypie-0.13.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/django-tastypie/Manifest b/dev-python/django-tastypie/Manifest
index 447face09b83..fcd33d1c934c 100644
--- a/dev-python/django-tastypie/Manifest
+++ b/dev-python/django-tastypie/Manifest
@@ -1 +1,2 @@
+DIST django-tastypie-0.13.3.tar.gz 231373 SHA256 7a6aac94911a09823e9f9f865d11845bbc9d7627eb44fa010650595c54c4596b SHA512 a4497c2212e1ca6614d69c8c847aedd9b9bb88c7c9083c3eae8bd163e9f61f4402c6adc0a3b2a5632e9d2d7e14b2158bce66d8e62257493edfbd9ca9be9355fb WHIRLPOOL 2f70f71651d1208748745c81d9ddfc84420333397863f4f2635c9575a80ab307059ebdad14eb08cad6f30112dd649d413711abbc6cb6c8fc6afbc96a4f9f3da5
DIST django-tastypie-0.9.15.tar.gz 206823 SHA256 1509d8a93d4f0e16434469c5af850d3c1c625da902b54216771cc7b25634216a SHA512 dcb26f7bb131e658ff6a2d11ca8eb74db064986cd48e536fb4987a1cfe4c4958e99f60cf173b1bbbbc051f3e55bc31ff28e645a52f526b3a98461daddd865a74 WHIRLPOOL 62503c0f05e429950b2aacdbaeacfa2cc71eee24fad9e365373fda473b7bf54e3a251ec0b3133f128436922abc4ed8182f7405eb4a62e1a40628b2b44b596243
diff --git a/dev-python/django-tastypie/django-tastypie-0.13.3.ebuild b/dev-python/django-tastypie/django-tastypie-0.13.3.ebuild
new file mode 100644
index 000000000000..ca895ffc973e
--- /dev/null
+++ b/dev-python/django-tastypie/django-tastypie-0.13.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A flexible and capable API layer for django utilising serialisers"
+HOMEPAGE="https://pypi.python.org/pypi/django-tastypie/ https://github.com/toastdriven/django-tastypie"
+SRC_URI="https://github.com/toastdriven/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="bip doc test"
+
+LICENSE="BSD"
+SLOT="0"
+
+COMMON_DEPEND=">=dev-python/mimeparse-0.1.4[${PYTHON_USEDEP}]
+ !=dev-python/mimeparse-1.5[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
+ !=dev-python/python-dateutil-2.0[${PYTHON_USEDEP}]
+ >=dev-python/django-1.7[${PYTHON_USEDEP}]
+ <dev-python/django-1.10[${PYTHON_USEDEP}]"
+
+RDEPEND="${COMMON_DEPEND}
+ bip? ( dev-python/biplist[${PYTHON_USEDEP}] )"
+
+#dev-python/pyyaml is pulled in with django itself
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${COMMON_DEPEND}
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.1.0[${PYTHON_USEDEP}]' python2_7)
+ >=dev-python/pytz-2013b[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/django-1.9[${PYTHON_USEDEP}]
+ <dev-python/django-1.10[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.1.0[${PYTHON_USEDEP}]' python2_7)
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="test? ( bip )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}