summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-23 07:25:25 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-23 07:41:24 +0100
commit011910138b5940b221c013190b3c097a90118b01 (patch)
treea9bb7ffbc5bc0770ff1314aa7909b2da199bbe61 /dev-python/djangorestframework
parentdev-python/djangorestframework: Remove old (diff)
downloadgentoo-011910138b5940b221c013190b3c097a90118b01.tar.gz
gentoo-011910138b5940b221c013190b3c097a90118b01.tar.bz2
gentoo-011910138b5940b221c013190b3c097a90118b01.zip
dev-python/djangorestframework: Bump to 3.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/djangorestframework')
-rw-r--r--dev-python/djangorestframework/Manifest1
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.15.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
index bf5c93b19aae..dc457fb9c030 100644
--- a/dev-python/djangorestframework/Manifest
+++ b/dev-python/djangorestframework/Manifest
@@ -1 +1,2 @@
DIST django-rest-framework-3.15.0.gh.tar.gz 9293419 BLAKE2B c6884185b8a11ca044956ec15bf3d31c3c46d8a911128f37ab305d89540a223e4b04ac4c13fc107333e9774ee048505f6cd0c66989f9f3cc9511239354572d25 SHA512 1b283fea0a94d64ea29bef59f18b5cb309627b7b927d80cdaad11d1fa9c4df2e2059d619ca5a73f382fa21bf847a266926542c1a1f5764bd6404d7c11861efab
+DIST django-rest-framework-3.15.1.gh.tar.gz 9291840 BLAKE2B daf672a1fb01494f08dd54af7369bd464d4fc1e22ff3c90c0fe787408d4f327710c5e6394e33546a4df2da752dbd774980f092108f2f4e395795af3aead18f89 SHA512 e44c3d861973928194035364fb6b5ddffbcacab959072b2c549971dd6675b5a5f1be13b55856154dbffaefb48dcbd4a63fd9ffbce5456507b52fd5e4648706b9
diff --git a/dev-python/djangorestframework/djangorestframework-3.15.1.ebuild b/dev-python/djangorestframework/djangorestframework-3.15.1.ebuild
new file mode 100644
index 000000000000..4bcf2d5c27de
--- /dev/null
+++ b/dev-python/djangorestframework/djangorestframework-3.15.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=django-rest-framework-${PV}
+DESCRIPTION="Web APIs with django made easy"
+HOMEPAGE="
+ https://www.django-rest-framework.org/
+ https://github.com/encode/django-rest-framework/
+ https://pypi.org/project/djangorestframework/
+"
+SRC_URI="
+ https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-3.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/inflection[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
+
+ # require coreapi (but not skipped properly)
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_default_schema_with_custom_title_url_and_desc
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_openapi_json_schema
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_renders_corejson_schema
+
+ # upstream is removing pytz, apparently it's not tested anymore
+ # https://github.com/encode/django-rest-framework/discussions/9342
+ tests/test_fields.py::TestPytzNaiveDayLightSavingTimeTimeZoneDateTimeField::test_invalid_inputs
+)