summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-09-08 22:47:07 +0300
committerSam James <sam@gentoo.org>2020-09-17 20:22:19 +0000
commit2f9c7c06ae380331593930a1fcc0faaa7e75d8e6 (patch)
tree69b6893aaf1a6942111d2f30f9bfd20c0e71d64a /dev-python/doit
parentdev-python/doit: update to 0.33.1 (diff)
downloadgentoo-2f9c7c06ae380331593930a1fcc0faaa7e75d8e6.tar.gz
gentoo-2f9c7c06ae380331593930a1fcc0faaa7e75d8e6.tar.bz2
gentoo-2f9c7c06ae380331593930a1fcc0faaa7e75d8e6.zip
dev-python/doit: remove old version
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17475 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/doit')
-rw-r--r--dev-python/doit/doit-0.32.0-r1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/doit/doit-0.32.0-r1.ebuild b/dev-python/doit/doit-0.32.0-r1.ebuild
deleted file mode 100644
index 0bdfcaf80c3a..000000000000
--- a/dev-python/doit/doit-0.32.0-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Automation tool"
-HOMEPAGE="https://pydoit.org/ https://pypi.org/project/doit/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-RDEPEND="
- dev-python/cloudpickle[${PYTHON_USEDEP}]
- dev-python/pyinotify[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="
- test? (
- ${RDEPEND}
- $(python_gen_impl_dep sqlite)
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pyflakes[${PYTHON_USEDEP}]
- >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
- )"
-PDEPEND=">=dev-python/doit-py-0.4.0[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
-
-PATCHES=(
- "${FILESDIR}/${P}_pytest5.4.patch"
- "${FILESDIR}/${P}_unpickable.patch"
-)
-
-src_prepare() {
- default
- # Replace custom theme with builtin for documentation
- sed -i -e "s:'press':'sphinx_rtd_theme':" doc/conf.py || die
- # Disable test failing due to impact on PATH run in a sandbox
- sed -i -e "s:test_target:_&:" tests/test_cmd_strace.py || die
-}
-
-src_install() {
- distutils-r1_src_install
- newbashcomp bash_completion_doit ${PN}
- insinto /usr/share/zsh/site-functions
- newins zsh_completion_doit _${PN}
-}