summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-09-18 16:46:51 +0200
committerFabian Groffen <grobian@gentoo.org>2017-09-19 08:54:09 +0200
commit126e355ec2b9ef894f00c34150d63bedc1f801e1 (patch)
tree878bb705cc50a9b991d57c7a62b6008b7bc0ddaa /dev-python/dulwich
parentapp-text/extract_url: initial import (diff)
downloadgentoo-126e355ec2b9ef894f00c34150d63bedc1f801e1.tar.gz
gentoo-126e355ec2b9ef894f00c34150d63bedc1f801e1.tar.bz2
gentoo-126e355ec2b9ef894f00c34150d63bedc1f801e1.zip
dev-python/dulwich: bump to 0.18.3, closes #631220
Package-Manager: Portage-2.3.8, Repoman-2.3.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/Manifest1
-rw-r--r--dev-python/dulwich/dulwich-0.18.3.ebuild50
-rw-r--r--dev-python/dulwich/files/dulwich-0.18.3-skip-failing-test.patch20
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index adc0aa81792f..24820064161d 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,4 +1,5 @@
DIST dulwich-0.13.0.tar.gz 289213 SHA256 8ed35334e22cf93e7dcfd5113d8e262041967fe4c3cead5e262c9102f3e63238 SHA512 5d62f81f45701c4e543483c89db696295b8c6aff413fa595a704b27421d5e0a99132a5c19c9b5511f96261c6a2c7d96e269ce9da526dec001b9a2fbc41413812 WHIRLPOOL abdc1877dbdc4499fbf888635287892376c58007515b32cd48d25662519e4708a79aa6f9b6b6b60b282b5f86646c0c6ca36c29516a0bf864bb998a2f4bd8216f
DIST dulwich-0.14.1.tar.gz 292827 SHA256 7c1f49e6e72fa8635328d32bfeb7103e86e175d87fa80a9cefdd63a360f7ba93 SHA512 95c996c101fa591bb5f94f98ad3c3b2426e678a0d5ee663fb42a8b2e93bb220e9fd18d3e943d3dbc913098111e1dd090f0751a17e1b71431a2175dcd3b711ea2 WHIRLPOOL 495a33fa1fb34368008a9c73acb3185032805f4e11a180022c7236b05c421d4ba71d32958d6ea9a602fdf238b83a23feb2c50a30726bad504978705b426b7d4f
DIST dulwich-0.17.3.tar.gz 311704 SHA256 0c3eccac93823e172b05d57aaeab3d6f03c6c0f1867613606d1909a3ab4100ca SHA512 1cc7950d53b8d8bb98f9206e1ced74857f756d4355813ddb2463cef855419ac57ae411e422e500b736c3e577f71da70d675d1f172140d4cc0645d3d5ab9e6e32 WHIRLPOOL c094224fd8c8f135114a7a91f4bbf509f7c28c24d3cdf8e6af25f8ccbbab6fb1bbe39fae1594429844746f6e006f4a63b9536fa84ecd3d617c6c6f5a2a2d5fe2
+DIST dulwich-0.18.3.tar.gz 328891 SHA256 d34c2628f89a5ac632fa462b2edd5afcfbf512793cfa14452d4c52f786962a8a SHA512 c89ae096407b59b37c2c36e7a429f2162950a0ee93f0ac619ea74c7ce48231ad9af097203dc8d9e2cd59bf1962f9c13325de61e9988c402fd3e212aacd910898 WHIRLPOOL 6d7aa5dd97fbc61d4248dc44626375ff465b132ae7c4ef8b60a473f138e53beb909e23e7a2fa2307a8bf44a8df52ff87f8958a41830ba16783918494d1668e01
DIST dulwich-0.9.9.tar.gz 270127 SHA256 084e762c8d4d0c0002823249db57b8e735c99c409dacc2849565dd3c0c288496 SHA512 5039e8e80c51b8ee0df2ba0805fa63d9b476a05c86b6bd9eaf9348ac03a83f0f1208e259ae6bcf40fb2c94ffb57c9b45bff852e367b8bee95c10e672d3dc19d5 WHIRLPOOL 2a79d25f1233d9a6a242d064af179486810555eb3c9803c336ae152095318a32eb8588779cb07f84b073a05bf7f083ba3b3d4c8d2b4f8929b2aa3d01c29a0a01
diff --git a/dev-python/dulwich/dulwich-0.18.3.ebuild b/dev-python/dulwich/dulwich-0.18.3.ebuild
new file mode 100644
index 000000000000..2ebf7ec54dfa
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.18.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="https://github.com/jelmer/dulwich/ https://pypi.python.org/pypi/dulwich"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/geventhttpclient[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-fastimport[${PYTHON_USEDEP}]
+ )"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+# One test sometimes fails
+# https://github.com/jelmer/dulwich/issues/541
+PATCHES=( "${FILESDIR}/${P}-skip-failing-test.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake check
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ docompress -x "/usr/share/doc/${PF}/examples"
+ doins -r examples
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dulwich/files/dulwich-0.18.3-skip-failing-test.patch b/dev-python/dulwich/files/dulwich-0.18.3-skip-failing-test.patch
new file mode 100644
index 000000000000..210908591dc2
--- /dev/null
+++ b/dev-python/dulwich/files/dulwich-0.18.3-skip-failing-test.patch
@@ -0,0 +1,20 @@
+diff --git a/dulwich/tests/test_porcelain.py b/dulwich/tests/test_porcelain.py
+index aa8587f..d1ffb9c 100644
+--- a/dulwich/tests/test_porcelain.py
++++ b/dulwich/tests/test_porcelain.py
+@@ -41,6 +41,7 @@ from dulwich.objects import (
+ )
+ from dulwich.repo import Repo
+ from dulwich.tests import (
++ SkipTest,
+ TestCase,
+ )
+ from dulwich.tests.utils import (
+@@ -634,6 +635,7 @@ class ResetTests(PorcelainTestCase):
+ class PushTests(PorcelainTestCase):
+
+ def test_simple(self):
++ raise SkipTest("broken")
+ """
+ Basic test of porcelain push where self.repo is the remote. First
+ clone the remote, commit a file to the clone, then push the changes