summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-22 07:22:42 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-22 07:59:43 +0200
commit9ab6de53299e59cb73c458f7c7cd82392d92b682 (patch)
tree1c803dff72210efccc9a8e6e3663c38a660add6e /dev-python/editorconfig-core-py
parentgnome-base/gnome-desktop:2: Remove (diff)
downloadgentoo-9ab6de53299e59cb73c458f7c7cd82392d92b682.tar.gz
gentoo-9ab6de53299e59cb73c458f7c7cd82392d92b682.tar.bz2
gentoo-9ab6de53299e59cb73c458f7c7cd82392d92b682.zip
dev-python/editorconfig-core-py: Enable py3.{7,8}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/editorconfig-core-py')
-rw-r--r--dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild b/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild
index 97128a013059..c9cfa0e96b43 100644
--- a/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild
+++ b/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild
@@ -4,7 +4,7 @@
EAPI=6
TESTVER="abb579e00f2deeede91cb485e53512efab9c6474"
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
DESCRIPTION="Clone of EditorConfig core written in Python"
@@ -43,11 +43,8 @@ python_install() {
#use cli || rm -f "${D}/${EPREFIX}"/usr/bin
}
-src_test() {
- __src_test_run_python_impl() {
- cmake -DPYTHON_EXECUTABLE="${PYTHON}" . || die "tests failed to build with ${EPYTHON}"
- ctest . || die "tests failed with ${EPYTHON}"
- }
- python_foreach_impl __src_test_run_python_impl
- unset __src_test_run_python_impl
+python_test() {
+ cmake -DPYTHON_EXECUTABLE="${PYTHON}" . ||
+ die "tests failed to build with ${EPYTHON}"
+ ctest . || die "tests failed with ${EPYTHON}"
}