summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-26 23:36:58 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-27 00:19:47 +0100
commitf7a610c170151a57d1a0dbb9cfeb01905bcba078 (patch)
treeeeffc7005b35227437388bc134761da9f0a62e70 /dev-python/enrich
parentdev-python/tzlocal: Keyword 4.1-r1 alpha, #831182 (diff)
downloadgentoo-f7a610c170151a57d1a0dbb9cfeb01905bcba078.tar.gz
gentoo-f7a610c170151a57d1a0dbb9cfeb01905bcba078.tar.bz2
gentoo-f7a610c170151a57d1a0dbb9cfeb01905bcba078.zip
dev-python/enrich: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/enrich')
-rw-r--r--dev-python/enrich/enrich-1.2.7-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/enrich/enrich-1.2.7-r1.ebuild b/dev-python/enrich/enrich-1.2.7-r1.ebuild
new file mode 100644
index 000000000000..2cb4fa26d981
--- /dev/null
+++ b/dev-python/enrich/enrich-1.2.7-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extend rich functionality"
+HOMEPAGE="https://github.com/pycontribs/enrich"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="dev-python/rich[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest-mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest