summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 17:16:41 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 17:37:33 +0200
commite3f33bdb8b7a8b1920095dadc19d7835962fedb4 (patch)
tree7a9de9fefc80a2d859fe9538545a099f8b3424bd /dev-python/fixtures/fixtures-3.0.0-r1.ebuild
parentdev-python/unittest2: Remove python2 (diff)
downloadgentoo-e3f33bdb8b7a8b1920095dadc19d7835962fedb4.tar.gz
gentoo-e3f33bdb8b7a8b1920095dadc19d7835962fedb4.tar.bz2
gentoo-e3f33bdb8b7a8b1920095dadc19d7835962fedb4.zip
dev-python/fixtures: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fixtures/fixtures-3.0.0-r1.ebuild')
-rw-r--r--dev-python/fixtures/fixtures-3.0.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/fixtures/fixtures-3.0.0-r1.ebuild b/dev-python/fixtures/fixtures-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..f73b73f73f96
--- /dev/null
+++ b/dev-python/fixtures/fixtures-3.0.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixtures, reusable state for writing clean tests and more"
+HOMEPAGE="https://launchpad.net/python-fixtures https://pypi.org/project/fixtures/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# nose not listed but provides coverage output of tests
+# run of test files by python lacks any output except on fail
+RDEPEND="
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ # broken on py3.9
+ # https://github.com/testing-cabal/fixtures/issues/44
+ sed -i -e 's:test_patch_classmethod_with:_&:' \
+ fixtures/tests/_fixtures/test_monkeypatch.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ emake check
+}