summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-04 20:20:03 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-04 20:20:03 +0200
commit5140974361132860b7a219a4f33eade07d1e092a (patch)
tree8301edb3fe68c9dd28a4ed81c8c15a17c2940655 /dev-python/flake8-polyfill
parentdev-python/flake8-polyfill: enable py3.11 (diff)
downloadgentoo-5140974361132860b7a219a4f33eade07d1e092a.tar.gz
gentoo-5140974361132860b7a219a4f33eade07d1e092a.tar.bz2
gentoo-5140974361132860b7a219a4f33eade07d1e092a.zip
dev-python/flake8-polyfill: use pep517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/flake8-polyfill')
-rw-r--r--dev-python/flake8-polyfill/flake8-polyfill-1.0.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/flake8-polyfill/flake8-polyfill-1.0.2-r1.ebuild b/dev-python/flake8-polyfill/flake8-polyfill-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..43a2e3378dbd
--- /dev/null
+++ b/dev-python/flake8-polyfill/flake8-polyfill-1.0.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Polyfill package for Flake8 plugins"
+HOMEPAGE="https://gitlab.com/pycqa/flake8-polyfill"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Get rid of the test that seems to test only the migration from
+ # pep8 to pycodestyle (bug 598918).
+ tests/test_stdin.py
+)
+
+src_prepare() {
+ sed -e 's|\[pytest\]|\[tool:pytest\]|' -i setup.cfg || die
+ distutils-r1_src_prepare
+}