summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-24 08:29:32 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-24 09:06:59 +0200
commit2ba53f316b301904c396ace768233860d5499d19 (patch)
treed2daf7e770b5893bed5d2695cad6000b70129cc3 /dev-python/flask-principal
parentdev-python/flask-mail: Port to py3.9 (diff)
downloadgentoo-2ba53f316b301904c396ace768233860d5499d19.tar.gz
gentoo-2ba53f316b301904c396ace768233860d5499d19.tar.bz2
gentoo-2ba53f316b301904c396ace768233860d5499d19.zip
dev-python/flask-principal: Port to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-principal')
-rw-r--r--dev-python/flask-principal/flask-principal-0.4.0-r1.ebuild11
1 files changed, 2 insertions, 9 deletions
diff --git a/dev-python/flask-principal/flask-principal-0.4.0-r1.ebuild b/dev-python/flask-principal/flask-principal-0.4.0-r1.ebuild
index ac5c8e80ea8f..19c475d31766 100644
--- a/dev-python/flask-principal/flask-principal-0.4.0-r1.ebuild
+++ b/dev-python/flask-principal/flask-principal-0.4.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
DESCRIPTION="Identity management for flask"
@@ -14,15 +14,8 @@ SRC_URI="https://github.com/mattupstate/${PN}/archive/${PV}.tar.gz -> ${P}.tar.g
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
dev-python/blinker[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-python_test() {
- nosetests -v || die "Testing failed with ${EPYTHON}"
-}
+distutils_enable_tests nose