summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/fonttools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest2
-rw-r--r--dev-python/fonttools/fonttools-2.4.ebuild28
-rw-r--r--dev-python/fonttools/fonttools-2.5.ebuild28
-rw-r--r--dev-python/fonttools/metadata.xml10
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
new file mode 100644
index 000000000000..605b70fc8f97
--- /dev/null
+++ b/dev-python/fonttools/Manifest
@@ -0,0 +1,2 @@
+DIST fonttools-2.4.tar.gz 348885 SHA256 95e5d8a67e2dae3ea237f9bebc449e0af42f12f03683db34f617e5b15d9d4fb0 SHA512 d63f4d715b2af2716145e6798cfbcde5a96da0d778f1a394bf8850afb0d4643ee87399a031c1f97f67d46ec545eb548ef137e794b1b02964ad04d54e468ac570 WHIRLPOOL dfc654fb40ec8cb7f7c3767e33bcdf6a0048ff42b53f97e9df893402f8470f95ba85dda436263b3f4a5281d19f48d8b21b2be551973421a17b6ed25ff211eef0
+DIST fonttools-2.5.tar.gz 229374 SHA256 c89603f9f3346f48f4a24f786422e935423554e0a9172dcd3ec8ffbd556d2159 SHA512 03e5943dbf821563d1997de50ee3a5d46c56d22d8ec48d03211fe4c51913154da36655bce5f5b003551fbcc7daa39919f1d1d21f2dd8d61c1f6186cee74f694f WHIRLPOOL 48b75a2b7b525c46f6de9b3b258873ef2965d9b9ba10679e4958e0dcde3d031c2ded9f8d7beb0dc41233ca028bc83ea3b4f75df6b4457f6f3a8ccf6b547af45f
diff --git a/dev-python/fonttools/fonttools-2.4.ebuild b/dev-python/fonttools/fonttools-2.4.ebuild
new file mode 100644
index 000000000000..eeb2dc356498
--- /dev/null
+++ b/dev-python/fonttools/fonttools-2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="http://fonttools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ia64 ppc x86"
+IUSE=""
+
+DEPEND=">=dev-python/numpy-1.0.2[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ DOCS=( README.txt Doc/{changes.txt,install.txt} )
+ HTML_DOCS=( Doc/documentation.html )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/fonttools/fonttools-2.5.ebuild b/dev-python/fonttools/fonttools-2.5.ebuild
new file mode 100644
index 000000000000..2c5409582d66
--- /dev/null
+++ b/dev-python/fonttools/fonttools-2.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/behdad/fonttools/"
+SRC_URI="https://github.com/behdad/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/numpy-1.0.2[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ DOCS=( README.md Doc/{changes.txt,install.txt} )
+ HTML_DOCS=( Doc/documentation.html )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/fonttools/metadata.xml b/dev-python/fonttools/metadata.xml
new file mode 100644
index 000000000000..36fc172f9f88
--- /dev/null
+++ b/dev-python/fonttools/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>fonts</herd>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="sourceforge">fonttools</remote-id>
+ <remote-id type="github">behdad/fonttools</remote-id>
+ </upstream>
+</pkgmetadata>