summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 12:01:46 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 12:03:58 +0200
commita12881b757491c6561aa89482c548ba20ab6c9fb (patch)
treeb68658fbeeb44a0a29211949888c738b042d3a32 /dev-python/fqdn
parentdev-python/tomlkit: Enable py3.11 (diff)
downloadgentoo-a12881b757491c6561aa89482c548ba20ab6c9fb.tar.gz
gentoo-a12881b757491c6561aa89482c548ba20ab6c9fb.tar.bz2
gentoo-a12881b757491c6561aa89482c548ba20ab6c9fb.zip
dev-python/fqdn: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fqdn')
-rw-r--r--dev-python/fqdn/fqdn-1.5.1-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/fqdn/fqdn-1.5.1-r2.ebuild b/dev-python/fqdn/fqdn-1.5.1-r2.ebuild
new file mode 100644
index 000000000000..40f0652a7caa
--- /dev/null
+++ b/dev-python/fqdn/fqdn-1.5.1-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2018-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC-compliant FQDN validation and manipulation for Python"
+HOMEPAGE="
+ https://github.com/ypcrts/fqdn/
+ https://pypi.org/project/fqdn/
+"
+SRC_URI="
+ https://github.com/ypcrts/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs