summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-09-29 22:27:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-29 22:27:17 +0300
commit00bcf47c44493ea76aa698cd1e98a451f9ea4000 (patch)
treec04c07b8bf7df51fa00c328627a8a683feb611be /dev-python/fs
parentdev-python/weasyprint: add 60.1 (diff)
downloadgentoo-00bcf47c44493ea76aa698cd1e98a451f9ea4000.tar.gz
gentoo-00bcf47c44493ea76aa698cd1e98a451f9ea4000.tar.bz2
gentoo-00bcf47c44493ea76aa698cd1e98a451f9ea4000.zip
dev-python/fs: fix most issues for python3.12
This isn't done, but fixes most of the issues, and we are left with 2 failing tests which looks like a real issue. But I still prefer to push current changes to minimize future work to enable py3.12 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/fs')
-rw-r--r--dev-python/fs/fs-2.4.16.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/fs/fs-2.4.16.ebuild b/dev-python/fs/fs-2.4.16.ebuild
index 89667905fa83..42594826f09b 100644
--- a/dev-python/fs/fs-2.4.16.ebuild
+++ b/dev-python/fs/fs-2.4.16.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
inherit distutils-r1 optfeature pypi
DESCRIPTION="Filesystem abstraction layer"
@@ -40,6 +40,13 @@ EPYTEST_IGNORE=(
tests/test_ftpfs.py
)
+src_prepare() {
+ # fix for python 3.12
+ sed -e 's/self.assertRaisesRegexp/self.assertRaisesRegex/g' -i fs/test.py || die
+
+ distutils-r1_src_prepare
+}
+
pkg_postinst() {
optfeature "S3 support" dev-python/boto
optfeature "SFTP support" dev-python/paramiko