summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-24 14:31:18 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-24 14:31:58 -0500
commit6f0d73068a9eda3c8764ae162c230fa803d310c7 (patch)
tree07d20e6a1f31e85b359aedf1767526aa7406b1d7 /dev-python/fs
parentdev-python/dbus-python: arm64 stable (bug #700568) (diff)
downloadgentoo-6f0d73068a9eda3c8764ae162c230fa803d310c7.tar.gz
gentoo-6f0d73068a9eda3c8764ae162c230fa803d310c7.tar.bz2
gentoo-6f0d73068a9eda3c8764ae162c230fa803d310c7.zip
dev-python/fs: move tests to BDEPEND and use python_gen_cond_dep
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/fs')
-rw-r--r--dev-python/fs/fs-2.4.9.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/fs/fs-2.4.9.ebuild b/dev-python/fs/fs-2.4.9.ebuild
index bf26e5723f5f..baa94596f226 100644
--- a/dev-python/fs/fs-2.4.9.ebuild
+++ b/dev-python/fs/fs-2.4.9.ebuild
@@ -26,15 +26,16 @@ RDEPEND="
>=dev-python/six-1.10[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ $(python_gen_cond_dep '
dev-python/nose[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pyftpdlib[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/unittest2[${PYTHON_USEDEP}]
- )
-"
+ ' -3)
+)"
python_test() {
# python2_7 tests require dev-python/typing which is