summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-10 14:00:03 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-10 14:24:15 +0200
commit7600029976af32deb852fa587ced37c99f13ca05 (patch)
tree8c86c76c5b33a2e8f7d6a53c3fdf186d8c9d2faa /dev-python/fs
parentprofiles/targets/desktop: Do not enable ldap USE flag by default (diff)
downloadgentoo-7600029976af32deb852fa587ced37c99f13ca05.tar.gz
gentoo-7600029976af32deb852fa587ced37c99f13ca05.tar.bz2
gentoo-7600029976af32deb852fa587ced37c99f13ca05.zip
dev-python/fs: bump to 2.4.11, add doc
Also use pytest for tests and fix dependencies while removing obsolete ones. Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/fs')
-rw-r--r--dev-python/fs/Manifest1
-rw-r--r--dev-python/fs/fs-2.4.11.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/fs/Manifest b/dev-python/fs/Manifest
index c720930a7d8d..6cc97a643d27 100644
--- a/dev-python/fs/Manifest
+++ b/dev-python/fs/Manifest
@@ -1 +1,2 @@
+DIST fs-2.4.11.tar.gz 163986 BLAKE2B 953e50da7002512029c0a1a8e7fe8be3a7c31fc48e2c66f0fe7d71dc908aab734f724e09c16074c3e4cdd86c9c2e1a847aa21176af07311012090375a3a6808e SHA512 fe4596bf213f9b1721cd3c665e6af180d6617eea07afbaa9d83847dc3f7dfe64bca16c8ccb337d48bbb49bf0d2fef90903e3c4aecc63f61faac6a2b6f6c59cf6
DIST fs-2.4.9.tar.gz 126022 BLAKE2B bd7406ee0c22171af349bed6096f58bc749af30f3fae6b8532d7a2b07dd7f0a55165f4b4ab413d6ff7c8861fbe7784ae383a984d26c1cdb1bdc9100c4ae0b0df SHA512 594536eccc043547df4ec4fd1fc507d3fad2838ebb46768a11f142c68d42a776f9fa3cda8651421c6255314835a0283407ea49ebdce04af84a1646efaf5391e5
diff --git a/dev-python/fs/fs-2.4.11.ebuild b/dev-python/fs/fs-2.4.11.ebuild
new file mode 100644
index 000000000000..a71c92e9647c
--- /dev/null
+++ b/dev-python/fs/fs-2.4.11.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Not yet ready for 3.9
+# https://github.com/PyFilesystem/pyfilesystem2/issues/421
+PYTHON_COMPAT=( python3_{6,7,8} )
+# pkg_resources is used
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1 optfeature
+
+MY_PN="pyfilesystem2"
+
+DESCRIPTION="Filesystem abstraction layer"
+HOMEPAGE="
+ https://pypi.org/project/fs/
+ https://docs.pyfilesystem.org
+ https://www.willmcgugan.com/tag/fs/
+"
+# Tests from the PyPI tarball are broken
+# https://github.com/PyFilesystem/pyfilesystem2/issues/364
+SRC_URI="https://github.com/PyFilesystem/pyfilesystem2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pyftpdlib[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "S3 support" dev-python/boto
+ optfeature "SFTP support" dev-python/paramiko
+ optfeature "Browser support" dev-python/wxpython
+}