summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-16 05:33:02 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-16 05:33:02 +0200
commit14f0310df8a64ead66c6fa3cbcb2f71bd770fc36 (patch)
treeb1b714e598345ae60222ef13b488cb3da95be24a /dev-python/fsspec
parentdev-python/pgspecial: Bump to 2.1.2 (diff)
downloadgentoo-14f0310df8a64ead66c6fa3cbcb2f71bd770fc36.tar.gz
gentoo-14f0310df8a64ead66c6fa3cbcb2f71bd770fc36.tar.bz2
gentoo-14f0310df8a64ead66c6fa3cbcb2f71bd770fc36.zip
dev-python/fsspec: Bump to 2024.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2024.5.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 7576b8b44ccd..944bb8092e01 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1 +1,2 @@
DIST filesystem_spec-2024.3.1.gh.tar.gz 426712 BLAKE2B 9e9c60f581872559bd667e8e3fadcb5c4c56a727901ffc2328b67da6a4553ae2e4981f143838532faa59deb9b3f3926e1e2f0b2dd86daf49f93a1811d4e668a4 SHA512 6b93543b729eae898a71fb0249ed69973cb1d2dfcf0feac7d40fb69b40e1109739819acbec9f239023b8a5eaaba01377215458cb5c4c806741ed319433d8f570
+DIST fsspec-2024.5.0.tar.gz 400066 BLAKE2B 4f497fa8efe4897958414e2739c06fed54ecd67babb7cbdfeb0c1b595547213aed1fb15f97dbd2f7f61a84fef7f3a96f36bb1ab5a2f4ca94251e7dccd64afe22 SHA512 b8430350c56ecaeca9496b6de7910d7f4423e17beb4250dcb440d9af6ab34ed83e2e9304b474d4b5611a9ee0941c34eba5c62d5a1f7d0cc1384d976ae3266e7f
diff --git a/dev-python/fsspec/fsspec-2024.5.0.ebuild b/dev-python/fsspec/fsspec-2024.5.0.ebuild
new file mode 100644
index 000000000000..d5b9c6d035f3
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2024.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="
+ https://github.com/fsspec/filesystem_spec/
+ https://pypi.org/project/fsspec/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+# Note: this package is not xdist-friendly
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p pytest_mock -o tmp_path_retention_policy=all
+}