summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-21 06:19:33 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-21 06:32:26 +0200
commit610bc7ea8355bd5f2a2b3b25f320b9819c77394d (patch)
tree4d2e1a6b10b59a45005ad1a30388ae7b8ee160fc /dev-python/fsspec
parentdev-python/moto: Bump to 5.0.18 (diff)
downloadgentoo-610bc7ea8355bd5f2a2b3b25f320b9819c77394d.tar.gz
gentoo-610bc7ea8355bd5f2a2b3b25f320b9819c77394d.tar.bz2
gentoo-610bc7ea8355bd5f2a2b3b25f320b9819c77394d.zip
dev-python/fsspec: Bump to 2024.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2024.10.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index a744d57ec459..f3d2d3cef2d7 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1 +1,2 @@
+DIST filesystem_spec-2024.10.0.gh.tar.gz 415286 BLAKE2B 59e8a1457c528c350ef49da546ee8e15dc27031dde3c5b2ae4c97a7ec0a392010c8d1558c4a6569be07aebc272add9629c6e8e7fc7e392259bb5f72b47b65a3c SHA512 46542e494044e40110c3da879ec620daca15e3a18e3e0a318f0c98f18a08aa7c319fffdf396527e920f6bc5f17fbec5e4c2030ed6a9b8853720e513165dbc56d
DIST filesystem_spec-2024.9.0.gh.tar.gz 413991 BLAKE2B b4dbb17e39481d3d5ee900618b3bea036faec0ce84d95cf2e581feb59d0eb5cb1ecc73730b87bbeb175110db34d52db062bf8d94e82f27a28a6f1693e10c49e7 SHA512 2600f7b020019634ec3f4ffd2a66f458c04423f10c00afbfd99dabad7fca809af28792a5b8a6625c57548f8dc172ab0d9498cbfcd570cd1d04a905c079fe4fb9
diff --git a/dev-python/fsspec/fsspec-2024.10.0.ebuild b/dev-python/fsspec/fsspec-2024.10.0.ebuild
new file mode 100644
index 000000000000..a1a42e4ef47b
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2024.10.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="
+ https://github.com/fsspec/filesystem_spec/
+ https://pypi.org/project/fsspec/
+"
+# upstream removed tests in 2024.6.0
+SRC_URI="
+ https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+# Note: this package is not xdist-friendly
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p pytest_mock -o tmp_path_retention_policy=all
+}