summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-20 07:54:54 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-20 07:55:07 +0200
commit1d93cac2e0feedc96321ba6221e7c92387a74b4c (patch)
treeab52bce83e83cb7057daacdc19bd128cee476e23 /dev-python/funcy
parentnet-libs/grpc: drop 1.37.1-r2 (diff)
downloadgentoo-1d93cac2e0feedc96321ba6221e7c92387a74b4c.tar.gz
gentoo-1d93cac2e0feedc96321ba6221e7c92387a74b4c.tar.bz2
gentoo-1d93cac2e0feedc96321ba6221e7c92387a74b4c.zip
dev-python/funcy: add 1.17
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/funcy')
-rw-r--r--dev-python/funcy/Manifest1
-rw-r--r--dev-python/funcy/funcy-1.17.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/funcy/Manifest b/dev-python/funcy/Manifest
index ce164b749883..5e02c0d83cc4 100644
--- a/dev-python/funcy/Manifest
+++ b/dev-python/funcy/Manifest
@@ -1 +1,2 @@
DIST funcy-1.16.tar.gz 619331 BLAKE2B 55773e12356af6c7fac441cae186cb476f2acbba3b22efd902c2be460f0d021f829c5bf4351ce359fd2062ad47ad576bb74413152c64f2540a6a1b5f869f238e SHA512 e08397c49d66e6d0257b4b140483a139ffdb086dd98a277d499e5777474dc0c6d49055ca121fdc5a17964256d4970da495c09c50fdd2aef2af8839a9328a87ae
+DIST funcy-1.17.tar.gz 112383 BLAKE2B 150133f72ed165bdc9adc3a9f4954dfd5b846dea7b1ee2cae0d6621ebaec3e2ba986cd6596fd86482036aad6476913caec0868db9cf55c067fdbf62ac10953e2 SHA512 d48ce3b7a7b8ee7512df109d651f40ca4dadf681acca6ab0a4857a2ea408f20f6345b9b416ca8b1e924050a842648192b8fe79381c202361bc4d2e25bd55ad05
diff --git a/dev-python/funcy/funcy-1.17.ebuild b/dev-python/funcy/funcy-1.17.ebuild
new file mode 100644
index 000000000000..48dcf0ae3ec6
--- /dev/null
+++ b/dev-python/funcy/funcy-1.17.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A collection of fancy functional tools focused on practicality"
+HOMEPAGE="https://github.com/Suor/funcy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? ( dev-python/whatever[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests --install pytest