summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/genshi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/genshi')
-rw-r--r--dev-python/genshi/Manifest1
-rw-r--r--dev-python/genshi/files/genshi-0.6-html_test.patch37
-rw-r--r--dev-python/genshi/genshi-0.7.ebuild40
-rw-r--r--dev-python/genshi/metadata.xml5
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/genshi/Manifest b/dev-python/genshi/Manifest
new file mode 100644
index 000000000000..01aa62c85bb3
--- /dev/null
+++ b/dev-python/genshi/Manifest
@@ -0,0 +1 @@
+DIST Genshi-0.7.tar.gz 491579 SHA256 1d154402e68bc444a55bcac101f96cb4e59373100cc7a2da07fbf3e5cc5d7352 SHA512 2d0042d4da4566725ddd80b73c5b7be09f479f5529e4aa69903edc2a98905ff6de42a0d5a6f02986d7962deb7740c4a3acf6955a8b77fdb42d3cf4ca037de6bf WHIRLPOOL 5e1a7af061d28a581c8a028ae7343a2b80697eb8bca01c8609345a3f2146db190a596d3488c0bde5aa132ac930d591ff1babd033ccb532c7cac7d2931751f906
diff --git a/dev-python/genshi/files/genshi-0.6-html_test.patch b/dev-python/genshi/files/genshi-0.6-html_test.patch
new file mode 100644
index 000000000000..4f74d6b999f5
--- /dev/null
+++ b/dev-python/genshi/files/genshi-0.6-html_test.patch
@@ -0,0 +1,37 @@
+Add/Change #501 (test_sanitize_remove_src_javascript fails due to HTMLParser bugfixes in cpython)
+Add/Change #500 (test_sanitize_remove_script_elem fails due to HTMLParser bugfixes in cpython)
+--- a/genshi/filters/tests/html.py
++++ b/genshi/filters/tests/html.py
+@@ -365,9 +365,12 @@
+ self.assertEquals('', (html | HTMLSanitizer()).render())
+ html = HTML('<SCRIPT SRC="http://example.com/"></SCRIPT>')
+ self.assertEquals('', (html | HTMLSanitizer()).render())
+- self.assertRaises(ParseError, HTML, '<SCR\0IPT>alert("foo")</SCR\0IPT>')
+- self.assertRaises(ParseError, HTML,
+- '<SCRIPT&XYZ SRC="http://example.com/"></SCRIPT>')
++ html = HTML('<SCR\0IPT>alert("foo")</SCR\0IPT>')
++ self.assertEquals('&lt;SCR\x00IPT&gt;alert("foo")',
++ (html | HTMLSanitizer()).render())
++ html = HTML('<SCRIPT&XYZ SRC="http://example.com/"></SCRIPT>')
++ self.assertEquals('&lt;SCRIPT&amp;XYZ; SRC="http://example.com/"&gt;',
++ (html | HTMLSanitizer()).render())
+
+ def test_sanitize_remove_onclick_attr(self):
+ html = HTML('<div onclick=\'alert("foo")\' />')
+
+--- a/genshi/filters/tests/html.py
++++ b/genshi/filters/tests/html.py
+@@ -437,9 +440,9 @@
+ # Case-insensitive protocol matching
+ html = HTML('<IMG SRC=\'JaVaScRiPt:alert("foo")\'>')
+ self.assertEquals('<img/>', (html | HTMLSanitizer()).render())
+- # Grave accents (not parsed)
+- self.assertRaises(ParseError, HTML,
+- '<IMG SRC=`javascript:alert("RSnake says, \'foo\'")`>')
++ # Grave accents.
++ html = HTML('<IMG SRC=`javascript:alert("RSnake says, \'foo\'")`>')
++ self.assertEquals('<img/>', (html | HTMLSanitizer()).render())
+ # Protocol encoded using UTF-8 numeric entities
+ html = HTML('<IMG SRC=\'&#106;&#97;&#118;&#97;&#115;&#99;&#114;&#105;'
+ '&#112;&#116;&#58;alert("foo")\'>')
+
diff --git a/dev-python/genshi/genshi-0.7.ebuild b/dev-python/genshi/genshi-0.7.ebuild
new file mode 100644
index 000000000000..b053ac351025
--- /dev/null
+++ b/dev-python/genshi/genshi-0.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_P="Genshi-${PV}"
+
+DESCRIPTION="Python toolkit for stream-based generation of output for the web"
+HOMEPAGE="http://genshi.edgewall.org/ http://pypi.python.org/pypi/Genshi"
+SRC_URI="http://ftp.edgewall.com/pub/genshi/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ "${PYTHON}" setup.py test
+}
+
+python_install_all() {
+ if use doc; then
+ dodoc doc/*.txt
+ dohtml -r doc/*
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/genshi/metadata.xml b/dev-python/genshi/metadata.xml
new file mode 100644
index 000000000000..ee7e8b2450a8
--- /dev/null
+++ b/dev-python/genshi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>