summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/git-python
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/git-python')
-rw-r--r--dev-python/git-python/Manifest3
-rw-r--r--dev-python/git-python/git-python-0.3.6.ebuild39
-rw-r--r--dev-python/git-python/git-python-1.0.0.ebuild39
-rw-r--r--dev-python/git-python/git-python-1.0.1.ebuild39
-rw-r--r--dev-python/git-python/metadata.xml9
5 files changed, 129 insertions, 0 deletions
diff --git a/dev-python/git-python/Manifest b/dev-python/git-python/Manifest
new file mode 100644
index 000000000000..04f1338a1ac0
--- /dev/null
+++ b/dev-python/git-python/Manifest
@@ -0,0 +1,3 @@
+DIST GitPython-0.3.6.tar.gz 353639 SHA256 f3f42ca085eedbd3a9956b5e639de58bbe77a119f6b3d5c3af27669a2322c4a9 SHA512 cfa70004c42580b858a030eb1b46c9827e33b4dbc5477934bf08809e001568a7314e21caacb36743e2b3575be005b4cf9d831fc26e9cbe1964c2808da222a161 WHIRLPOOL afee46f324d22de6ee1b5d1525a17e68e6fa84ef851cf4d44e4aa6f71ee55d26421716559ba446706b12afb45a692cd7b2c27659a58bcdd28f09063ff05961e0
+DIST GitPython-1.0.0.tar.gz 354662 SHA256 c1b3e6fdd209040b6b1cb32ecbff989eeb2fb31b4e7078c3342d71ae8ef7352b SHA512 02d6ca44c930cabd9aa7344ae2f97d201e1840cf22b6083e949f9f374113558b1d7ca88f2d5a4691e63d71da5e54418ef7b8807adb2dfcf90d843fe2d588b3f9 WHIRLPOOL 1623ffabe1bd9de7a71890e3794b45b5871ef519d2b7581f881b4df4e54dc529e5e75bd7835161900a4307ffabfa014f7e64dbe1cee9502b70821691c9853476
+DIST GitPython-1.0.1.tar.gz 355108 SHA256 9c88c17bbcae2a445ff64024ef13526224f70e35e38c33416be5ceb56ca7f760 SHA512 63fc061f0e045b11adf20ab291f9d614028d76fb44c6b0910193f6a9f4a5f9bae070527fa2ca06b234da12b7cd545194a7f5e912f4e09370bd41f81552c3160f WHIRLPOOL f166834a746d5e2a4888219aa86f897f2713dbcc94dd1f2444a3ffc1b292bb2ae0b83df51aebd65ef45b942ff6d48ebb08b26796818512af6fcafded90398d4e
diff --git a/dev-python/git-python/git-python-0.3.6.ebuild b/dev-python/git-python/git-python-0.3.6.ebuild
new file mode 100644
index 000000000000..745b21605a03
--- /dev/null
+++ b/dev-python/git-python/git-python-0.3.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="GitPython"
+MY_PV="${PV/_rc/.RC}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="http://gitorious.org/git-python http://pypi.python.org/pypi/GitPython"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# Tests dont make sense without a git repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-0.6.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+# $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+# is the correct entry for mock, however while RESTRICT="test"
+# there is little point in setting it since it is inactive
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/git-python/git-python-1.0.0.ebuild b/dev-python/git-python/git-python-1.0.0.ebuild
new file mode 100644
index 000000000000..76d7ffb41e8b
--- /dev/null
+++ b/dev-python/git-python/git-python-1.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="GitPython"
+MY_PV="${PV/_rc/.RC}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="http://gitorious.org/git-python http://pypi.python.org/pypi/GitPython"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# Tests dont make sense without a git repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-0.6.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+# $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+# is the correct entry for mock, however while RESTRICT="test"
+# there is little point in setting it since it is inactive
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/git-python/git-python-1.0.1.ebuild b/dev-python/git-python/git-python-1.0.1.ebuild
new file mode 100644
index 000000000000..76d7ffb41e8b
--- /dev/null
+++ b/dev-python/git-python/git-python-1.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="GitPython"
+MY_PV="${PV/_rc/.RC}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="http://gitorious.org/git-python http://pypi.python.org/pypi/GitPython"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# Tests dont make sense without a git repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-0.6.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+# $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+# is the correct entry for mock, however while RESTRICT="test"
+# there is little point in setting it since it is inactive
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/git-python/metadata.xml b/dev-python/git-python/metadata.xml
new file mode 100644
index 000000000000..5a31bf726ce5
--- /dev/null
+++ b/dev-python/git-python/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">GitPython</remote-id>
+ <remote-id type="gitorious">git-python</remote-id>
+ </upstream>
+</pkgmetadata>