summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-09 09:23:56 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-09 11:49:30 +0200
commit54aca4048fd0f870b57d442f864b351d96df87b0 (patch)
tree11f1f0d881b684fd39bd5b16604f3ff03e4d47f8 /dev-python/globre
parentdev-python/django-appconf: Version Bump (diff)
downloadgentoo-54aca4048fd0f870b57d442f864b351d96df87b0.tar.gz
gentoo-54aca4048fd0f870b57d442f864b351d96df87b0.tar.bz2
gentoo-54aca4048fd0f870b57d442f864b351d96df87b0.zip
dev-python/globre: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/globre')
-rw-r--r--dev-python/globre/Manifest1
-rw-r--r--dev-python/globre/globre-0.1.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/globre/Manifest b/dev-python/globre/Manifest
index c4a769236e57..54dd30a6201b 100644
--- a/dev-python/globre/Manifest
+++ b/dev-python/globre/Manifest
@@ -1 +1,2 @@
DIST globre-0.1.2.tar.gz 18465 SHA256 64203a0caca50cf2048cc4cc18b8abf452dfb7822b79ea9950f7c0ee03f51d9b SHA512 1e1a406b2a07ae551ba9b1b18dc92fc0728d2e0ad01c63a2108736430d893c427011b74883f5c84040426603ac8f46346a672e50a96502b315c02f81e6dff82c WHIRLPOOL eb4d5017438a946577d19ec2e2a2208a0edd5b4dd6136ce4aa71f73bd866b893396cc4b6cc4b9f592307d1116e2c04d54c83f3a47bc42e4738c29bbf915256dc
+DIST globre-0.1.3.tar.gz 19205 SHA256 482527dc342a88945edfbfe4d78b0c546b163b2a6579863ebfd6b3b5df222e5a SHA512 430c09cd459a9131da4ae086cff608c269445219fce5c86fa344e038eb3fa0cac1bbdf3d153d099083fc3ea1b45135a800420c230d44f5503beaf910d494cb37 WHIRLPOOL 35735832cad2bd4c00ddb211cb80a0f99b37a32d5914a1f87c9c32117f34a81e2b079a9e9bd052eee8c134c83eedefd4a3c9c446796ee2933050e241d7e774a7
diff --git a/dev-python/globre/globre-0.1.3.ebuild b/dev-python/globre/globre-0.1.3.ebuild
new file mode 100644
index 000000000000..ad75c8fa06ae
--- /dev/null
+++ b/dev-python/globre/globre-0.1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A glob matching library, providing an interface similar to the 're' module"
+HOMEPAGE="https://pypi.python.org/pypi/globre https://github.com/metagriffin/globre"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests --verbose || die
+}