summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-04 21:12:39 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-04 21:27:08 +0100
commita0d2848bd4db055617d50c932d9201ef7323aaaf (patch)
tree8f0b19251d2baeb608165a73f02a64565eb1ff40 /dev-python/google-auth-httplib2
parentdev-python/importlib_resources: Bump to 5.1.2 (diff)
downloadgentoo-a0d2848bd4db055617d50c932d9201ef7323aaaf.tar.gz
gentoo-a0d2848bd4db055617d50c932d9201ef7323aaaf.tar.bz2
gentoo-a0d2848bd4db055617d50c932d9201ef7323aaaf.zip
dev-python/google-auth-httplib2: Bump to 0.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth-httplib2')
-rw-r--r--dev-python/google-auth-httplib2/Manifest1
-rw-r--r--dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/google-auth-httplib2/Manifest b/dev-python/google-auth-httplib2/Manifest
index 5250f089c6f7..1524f431beb1 100644
--- a/dev-python/google-auth-httplib2/Manifest
+++ b/dev-python/google-auth-httplib2/Manifest
@@ -1 +1,2 @@
DIST google-auth-httplib2-0.0.4.tar.gz 11218 BLAKE2B a6f4b4cf29ba6db81d70dda16eef7c2d378cf1c38d1f3f2f27a38a7d293809a23a4ae38ef0515b8b1ce278bdfc4a15daa291cac0a70f7a84cf7c8f40e36e01c5 SHA512 a33e54d07c610dcb1e01118808792c3a259b7f1a579acbe3f92825ad5100b96a844168bb37327e71f078b870f1594b021d59d0c86c15868384f19ddb569b42cb
+DIST google-auth-httplib2-0.1.0.tar.gz 25116 BLAKE2B dbb0393bafb1bbe67b99ac0783e687271c42256c7b283422b884b86d4c8a83222392a5514b812aae683ec7f887afa4bf81307079e676f793f02eb87e52a375e5 SHA512 52b0faf70e185cb89420377a06c77e2c45f6b910b85371fc2c42fdfb06a4ebca28b476201f9d179fbaa4a8bf7b6015703d023ddd95d482113e2cdbf79fd376b5
diff --git a/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0.ebuild b/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0.ebuild
new file mode 100644
index 000000000000..8998da238e38
--- /dev/null
+++ b/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+MY_PN="google-auth-library-python-httplib2"
+DESCRIPTION="httplib2 Transport for Google Auth"
+HOMEPAGE="https://pypi.org/project/google-auth-httplib2/ https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2"
+SRC_URI="https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest